3

I'm trying to install landsat-util in an Ubuntu AWS instance. First, I created a Python 2.7 environment called landsat_py2 to avoid conflicts and the installation process seems to be fine. Nonetheless, when I run the help: landsat -h, the following appear:

(landsat_py2) imendieta@wef-oceans:~$ landsat -h
Traceback (most recent call last):
  File "/home/imendieta/.conda/envs/landsat_py2/bin/landsat", line 7, in <module>
    from landsat.landsat import __main__
  File "/home/imendieta/.conda/envs/landsat_py2/lib/python2.7/site-packages/landsat/landsat.py", line 29, in <module>
    from .image import Simple, PanSharpen, FileDoesNotExist
  File "/home/imendieta/.conda/envs/landsat_py2/lib/python2.7/site-packages/landsat/image.py", line 16, in <module>
    import rasterio
  File "/home/imendieta/.conda/envs/landsat_py2/lib/python2.7/site-packages/rasterio-0.32.0-py2.7-linux-x86_64.egg/rasterio/__init__.py", line 8, in <module>
    from rasterio._base import eval_window, window_shape, window_index
ImportError: libgdal.so.1: cannot open shared object file: No such file or directory

[UPDATE: After running $ conda install -c conda-forge gdal rasterio jpeg=8d matplotlib=1.5.1 the problem resolves and Landsat-util runs flawlessly.]

2

I had a similar issue and the following worked for me:

conda install -c conda-forge gdal rasterio jpeg=8d

2
  • Thanks for your suggestion, but errors keep coming (I update the question with the new errors). I have already issue the question in the GitHub repo. matplotlib version is kind of bugging. The same errors appear when I try in my local Mac machine. – topcat Jun 11 '17 at 10:54
  • Finally I could install the utility. I added matplotlib=1.5.1 to the installation of the other packages inside the virtual environment with Python 3.5 – topcat Jun 12 '17 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.