1

I'm trying to build Qgis on windows, and I'm following the instructions provided by Qgis, but I've had problems with the python interpreter already being in cmake-gui. I think the following error:

CMake Error at C:/Program Files/CMake/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:138 (message): Could NOT find PythonInterp: Found unsuitable version "1.4", but required is at least "3" (found C:/OSGeo4W64/bin/python3.exe) Call Stack (most recent call first): C:/Program Files/CMake/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:376 (_FPHSA_FAILURE_MESSAGE) C:/Program Files/CMake/share/cmake-3.7/Modules/FindPythonInterp.cmake:151 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:640 (FIND_PACKAGE)

I have been reading and says that it might have other versions installed, I have uninstalled all versions of python. But I still see the same, error, Verify that my executable was not damaged, it is not.

I'm installing everything on the 64-bit version, on a windows 10 machine, Visual studio 2015, Qt5, and python 3.6

Any idea how to fix it?

  • 1
    QGIS 2.18 does run with python 2.7. – Matte Jun 14 '17 at 16:47
  • Perhaps you may want to check your PATH settings. – hannbroo Jun 14 '17 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.