I tried to clip a DEM raster by extent, but I left it there for about 2 hours and got a 45GB file even though the original raster is actually 77MB. Since the process wasn't complete, I couldn't open the file. Based on what I have read, this might be related to the original raster being compressed... but could it really be this different (full data = 77mb, clipped region of interest = 45gb)? Also, I know that DEM files carry a lot of data, so it should take a decent amount of time... Should I leave it here for hours and forget about it? I thought my computer could be the problem, but I have never had such a problem using QGIS.

QGIS Version: 2.16.3

Processor: 2.5GHz

Memory: 8GB RAM

Storage: 256GB SSD (with 100GB free)

enter image description here

This is the setup i tried.

enter image description here

Raster info:

Driver: GTiff/GeoTIFF Size is 5400, 3600 Coordinate System is: PROJCS["SIRGAS 2000 / UTM zone 23S",
SPHEROID["GRS 1980",6378137,298.2572221010002,
AUTHORITY["EPSG","31983"]] Origin = (-48.000000000000000,-23.000000000000000) Pixel Size = (0.000277778481481,-0.000277777777778) Metadata:
INTERLEAVE=BAND Corner Coordinates:
Upper Left ( -48.0000000, -23.0000000) ( 45d 0' 0.00"W, 90d 0' 0.00"S)
Lower Left ( -48.0000000, -24.0000000) ( 45d 0' 0.00"W, 90d 0' 0.00"S)
Upper Right ( -46.4999962, -23.0000000) ( 45d 0' 0.00"W, 90d 0' 0.00"S)
Lower Right ( -46.4999962, -24.0000000) ( 45d 0' 0.00"W, 90d 0' 0.00"S)
Center ( -47.2499981, -23.5000000) ( 45d 0' 0.00"W, 90d 0' 0.00"S) Band 1 Block=5400x1 Type=Float32, ColorInterp=Gray
Min=-0.000 Max=1.000 Minimum=-0.000, Maximum=1.000, Mean=0.639, StdDev=0.233 Metadata:

  • 1
    what format is your DEM (if it is compressed it need to uncompress) hence why your temp files are large
    – Mapperz
    Jun 14, 2017 at 19:01
  • It says GTiff/GeoTIFF here, so .tif, right? Do you know how could I uncompress it? Jun 14, 2017 at 19:06
  • 2
    Add gdalinfo report about your DEM to your question and enough screenshots etc. that we know what you are really doing.
    – user30184
    Jun 14, 2017 at 19:21
  • I do not understand the metadata of your GeoTIFF. It claims to be in EPSG:31983 but the extents looks more like EPSG:4326 degree units. One by one and a half meter sized DEM is too small to be true. Where and how did you cat that DEM?
    – user30184
    Jun 14, 2017 at 21:37
  • do you have access to a copy of IDRISI/TerrSet software, or was this a download?
    – Steven Kay
    Jun 15, 2017 at 0:18

2 Answers 2


I may be misreading something here, but I see the image as a 1 degree by 1.5 degree area and the pixel size is 0.00027777 degrees. Just off the top of my head, if the value is decimal degrees, I think that would make the pixel size approximately thirty meters.

In looking at the screen shot, I am seeing an EPSG Zone of what I believe is 32622 (which is in the Northern Hemisphere UTM 22 N) and OTF is turned on.

I do not believe you want a negative value as large as is being displayed for the "Y" coordinate.

This is approximately where the coordinates plot out if using the that zone.

enter image description here

The Red rectangle depicts the boundary of that zone.

So here are a couple of options.

Option 1. Import the image into a project with OTF turned off and use EPSG Zone 31983 UTM 23 S

Here is a picture of that zone

enter image description here

This should match the metadata of the image, but I do not know if it will solve the clipping and export issue.

Option 2.

This is the one I would try first. Import the image using EPSG 4326, clip, and export it, then you could reproject it as necessary.

I agree with @user30184 that it appears to be EPSG 4326 after further investigation of the metadata. The pixel size of 0.0002777777 degrees would make sense if the image was Geographic, rather than projected.

  • The 1st option you gave solved it for me. Clipped the area I wanted within seconds! @user30184 also helped me understand the problem a lot since I am not that familiar with metadata. Jun 15, 2017 at 13:22

Because of crappy metadata in the DEM GeoTIFF file gdal_translate gets order to create an output raster with extents of 21057 x 11022 meters with pixel size of 0.00027777 meters. Those two factors together mean that the size of the requested output in pixels is

(21057/0.00027777) x (11022/0.00027777) = 75807322 x 39680311 pixels

That is a big image.

You should get correct metadata for your DEM before you can make anything reasonable with it. However, I do not understand how have you managed to open that, by the metadata, 1 by 1.5 meter DEM file into your QGIS so that it seems to make sense in the screen capture. Did it really open automatically that way or did you give CRS by hand?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.