I have an odd shaped (not square) raster .tiff file that I converted to MrSid using Lizardtech's GeoExpress. It converts the nodata to black. This is applying a value to no data.

Eventually I want to overlay this MrSid image on top of other layers, so the nodata cells need to be transparent.

How do I do this?


After a few trials and errors we came up with this solution. As with most GIS processing there are multiple ways to do things so although I am sure there are other, maybe better, ways this worked efficiently enough for us with the tools we had on hand and are most familiar with.

We took the raster.tiff and opened it in Global Mapper. We exported the raster to GeoTiff format, ensuring 24 bit and toggle on the "Make Background (Void) pixels transparent" option under TIFF Format Options.

When we used LizardTech to compress the file we toggled on lossless. This time when we loaded the MrSid image back into Global Mapper and ArcGIS 10.4 the image looked as we wanted. Now we can load it into our tablet software and the transition layers show up nicely.


If your wanting to view in GeoViewer, go to the Layer Controls for the raster and in this window scroll down to 'No Data Value' set this to 0 and all 0 values will become transparent.

You can do the same viewing in QGIS by going to layer properties, selecting the transparency tab and you have 3 sections to choose either global, no data or custom transparency ranges. In the No Data Value section, just set to 0 and all 0's will be transparent. Alternatively you can set ranges from say 0-100 as transparent in the Custom Transparancey Options section,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.