2

I am trying to import an Excel table into Whitebox (on Windows 10) and can't find a solution to preserve the attributes. I have UTM coordinates in the first and second column and two numerical attributes in the third and fourth colum (see screenshot below).

I tried to export as CSV or ASCII text and import it in whitebox. While the points are mostly located right the attributes get lost.

I tried different delimiters, deleted empty rows (one at the end), changed the encoding of the file, remove the first column,... but nothing had an effect. What I achieved was importing the attributes as strings but then I cannot interpolate the points as numbers and I don't want to convert the columns to integers in Whitebox as the workflow should consist of as few steps as possible (training reasons).

There must be a way how to do it so if anyone has a hint what else I could try I would be happy.

Edit: I also tried to use the English version of Whitebox instead of the German translation to prevent possible errors related to the comma but this didn't work. Also using CSV data with different delimiters (comma, point, semicolon) has no effect.

File structure: File structure

Import of XYZ data (ASCII text): XYZ data

Import of CSV data: csv data

  • 1
    From the look of the map it seems you are using German settings,...... changing it to English could potentially help? (You may have to reinstall Whitebox). I am wondering if csv delimiter may be a part of this issue...just a thought. – Kazuhito Jun 15 '17 at 15:37
  • Thank you for the suggestion. I also thought that the symbol for the comma or the delimiter could be a reason but none of my combinations worked so far. I didn't try the Language option however but I will report if this is the reason. – AndyB Jun 16 '17 at 5:50
  • 1
    Edit: I uninstalled Whitebox and restarted in English language but it didn't change anything. – AndyB Jun 16 '17 at 6:07
  • 1
    Thanks for your feed back. That's unfortunate... and sorry letting you take that effort. Do you mind add that information to your post? Like @Hornbydd my Whitebox 3.4 is working fine with csv and cannot reproduce this issue. (I am on Windows10, by the way). – Kazuhito Jun 16 '17 at 7:03
  • 1
    thank you for the suggestion. I also tried \t and " " als delimiters, but I receive an error (log file: java.lang.NumberFormatException: For input string: "504244 5374452 53") I tested it on two different machines so I guess there is something about the data which I currently oversee. – AndyB Jun 19 '17 at 7:50
1

When you run the Import CSV tool, did you set the 3rd and 4th column to "numerical attribute"?

I created an excel file with the first 3 rows of your data, saved as CSV and then imported into Whitebox, I just made sure I set all four columns. Worked for me.

Screenshot

  • Yes, I set the corresponding columns but they remain empty. If I select nothing no attribute columns are imported at all. Could you maybe provide your csv file so I can try and compare if yours is different? – AndyB Jun 16 '17 at 6:08
  • I found that when I am selecting "string attribute" the column is loaded into QGIS. But as a string I cannot interpolate the points. There must be a way to get the attributes into Whitebox as strings... – AndyB Jun 19 '17 at 17:28
  • 1
    @AndyB, Here is a sample of your data that loads into WhiteBox GAT using the Import CSV tool. All I did was copy from your screenshot, added the rows in Excel then Saved As "csv" – Hornbydd Jun 19 '17 at 18:08
  • thanks for responding. I'm still facing the same issue with your sample. I guess it is somehow related to the german language settings of my computer. My colleague didn't get it done on his machine as well. I already changed the decimal separator in the region settings of Windows but this didn't have an effect as well. Is there anyone from Germany who could try it? I can't be the only one who struggles with that... – AndyB Jun 20 '17 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.