0

I have a very simple problem with MapServer 7.0.4.

I am trying to display a point layer (WMS) with a simple circle but I can't get it to work.

Here is the CLASS definition in the layer object:

  CLASS

    STYLE
      SYMBOL "circle"
      SIZE 16
      COLOR 255 0 0
      OUTLINECOLOR 0 0 0
    END #STYLE

  END #CLASS

Here is the symbol definition, in a separate file called 'circle'

SYMBOL
  TYPE ellipse
  POINTS 1 1 END
  NAME "circle"
END

Here is the error from the log file:

[Fri Jun 16 09:47:51 2017].804000 readImage(): General error message. unsupported pixmap format
[Fri Jun 16 09:47:51 2017].804000 msDrawMap(): Image handling error. Failed to draw layer named 'sommets'.
3

Ah.. I had to post a question to solve it moments after!

In my map file (in the map object) I put the following symbol definition:

SYMBOL
    TYPE ellipse
    POINTS 1 1 END
    NAME "circle"
END

The symbol is defined BEFORE referencing the layer files. Here is an example:

[.....]


  PROJECTION
    "init=epsg:32198"
  END



    SYMBOL
        TYPE ellipse
        POINTS 1 1 END
        NAME "circle"
    END

    # Layers

    INCLUDE "lyr_hillshade.map"
    INCLUDE "lyr_dem.map"   

[....]

Then here is the CLASS object definition of the layer I wanted to style:

  CLASS

    STYLE
      SYMBOL "circle"
      SIZE 16
      COLOR 255 0 0
      OUTLINECOLOR 0 0 0
    END #STYLE

  END #CLASS
  • 1
    well saved me providing an answer... – nmtoken Jun 16 '17 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.