Every time I make a map I like to have more control over labels position so I manually move them. But today something weird occurred. I defined X and Y position of label to manually move them. Every time it was working but this time labels just disappear after saving the layer settings. What's wrong here ? The "Move Label" option is active but there is no feature to move...

I Use Qgis 2.14.15 on Windows 10 HOME. enter image description here

  • 1
    Did you select a field before setting the X and Y? Basing on the few information given, it seems to works for me.
    – mgri
    Commented Jun 18, 2017 at 20:53
  • I've just tried it. Not working. It's very weird. It seems that this method for manual label moving it's not working anymore on my QGIS.
    – muszynov
    Commented Jun 18, 2017 at 21:03
  • suggestion from @mgri is most likely, I often forget to set the field... If your label field is selected, make sure it isn't NULL. If it's an expression, make sure it works. Also, try checking the "show all labels (including colliding labels)" option
    – Steven Kay
    Commented Jun 18, 2017 at 22:14
  • Which coordinate System are you using? How many positions after the decimal point do you have? Can you make a screenshot of your attribute table?
    – AndreasK
    Commented Jun 19, 2017 at 6:56
  • For this project I use ETRS:LAEA (3035). I calculated X and Y coordinates for all features and It helped. But since yesterday, I didn't need to calculate them. Everytime when I was creating X and Y columns they got Lenght and precision set to 10 and it was working.
    – muszynov
    Commented Jun 19, 2017 at 8:28

2 Answers 2


The distance you specified is 2 meters.... So every label is 2m away from the point. Not map-meters, but on screen meters. Try panning (a lot) to see the labels.

--> remove the 2000 mm setting

  • It's not working. I was trying to do it on new 'fresh' project. Labels are still dissapering.
    – muszynov
    Commented Jun 18, 2017 at 20:55

I finally found a way how to over come this problem.

Just change the x and y columns in the attribute table to decimal with a maximum degree of precision, in this way if your coordinate system is in decimal, so the problem will occur no more b/c you already had a maximum degree of precision for moving your labels.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.