1

I'm trying to display some WMS with tiles, but at every zoom (in or out) the images are displaying wrong, with wrong proportions. This is how I'm creating the tile:

    var map = this.state.map;
    var layers =
        new ol.layer.Tile({
            source: new ol.source.TileWMS({
                url: 'http://XX.XX.XX:8080/geoserver/cite/wms',
                params: {'LAYERS': 'cite:clientes_ex', 'TILED': true, 'VERSION': '1.3.0',
                    'FORMAT': 'image/png8', 'WIDTH': 256, 'HEIGHT': 256, 'CRS': 'EPSG:3857'},
                serverType: 'geoserver'
            })
        })
    map.addLayer(layers);

This is what happens. enter image description here

This is another example, in zooms very far way from the map: enter image description here

Any idea how could I fix it?

4
  • I have the similar problem when using map projection: 'EPSG:3035'. ![enter image description here](i.sstatic.net/skZHj.jpg) But tiles displays in correct order with map projection: 'EPSG:3857'. Any reason why is that happening? Commented Aug 3, 2017 at 11:42
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Oto Kaláb
    Commented Aug 3, 2017 at 12:14
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review
    – Kersten
    Commented Aug 3, 2017 at 13:53
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review
    – mgri
    Commented Aug 3, 2017 at 14:12

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.