3

This question seems simple but I couldn't get it done for most of the layers I tested:

This is the adress that is predefined. It works with a small subset ogc.bgs.ac.uk/cgi-bin/BGS_Bedrock_and_Superficial_Geology/wms

I tried several others but keep getting Tool Execution Failed

These all work in QGIS but not in SAGA:

I understood it as follows (and so worked the first example):

  1. Open Import a Map Via Web Map Service (WMS)
  2. Insert the address, leave all other fields
  3. Hit Okay
  4. The image pops up again (see below), enter extents and select bands
  5. Hit Okay

Works for me with the given default address but not with the others. Any ideas?

Add WMS in SAGA

  • Are you saying that the BGS service works sometimes, but the others don't ever? – nmtoken Jun 21 '17 at 20:09
  • exactly. If extent coordinates are given correctly the BGS service works fine. All others result in an error ("Tool execution failed" and " Unable to get map"). I already tried extent coordinates in degree and meters (as for UTM) but none of them worked. – AndyB Jun 22 '17 at 6:33
1

I ran a quick test on my version of SAGA and get the same error reported Tool execution failed.

If I look in the logs I see the following message:

2017-06-24/13:32:39] Executing tool: Import a Map via Web Map Service (WMS)
Parameters
WMS Map: <not set>
Server: www.webatlasde.de/arcgis/services/Maps4BW/MapServer/WMSServer
User Name: 
Left: 7.116445
Right: 10.861333
Bottom: 47.289293
Top: 50.029696
Layer: Halbtonvariante

[2017-06-24/13:33:02] /arcgis/services/Maps4BW/MapServer/WMSServer?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&LAYERS=Halbtonvariante&SRS=EPSG:4326&FORMAT=image/png&WIDTH=2002&HEIGHT=1465&BBOX=7.116445,47.289293,10.861333,50.029696
[2017-06-24/13:33:03] could not read image
[2017-06-24/13:33:03] 
rsion="1.0" encoding="UTF-8" standalone="no" ?>
<!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.1/exception_1_1_1.dtd">
<ServiceExceptionReport version="1.1.1">
  <ServiceException code="StylesNotDefined">
Parameter 'styles' is required.
  </ServiceException>
</ServiceExceptionReport>

So ArcGIS, in this case, is expecting a styles parameter to be passed in the GetMap request but does not receive one. The WMS 1.1.1 standard tells us that a styles parameter is required, unless an SLD parameter is present, (even if it is empty like styles& when the default style is used) and therefore ArcGIS is correct in not responding to the request. In other words this appears to be an error with SAGA in not sending a styles parameter. The BGS (MapServer) service ignores the error (against the specification) and returns a default style.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.