2

I'm using this code which I got from U-PENN geog 585:

https://www.e-education.psu.edu/geog585/node/718

                  var response = JSON.parse(event.text);
                  if(response.features.length !== 0){
                    var returnedFeature = response.features[0];
                    // Configure the popup
                    map.addPopup(new OpenLayers.Popup.FramedCloud(
                      "marketInfo",
                      map.getLonLatFromPixel(event.xy),
                      null,
                      "<b>" + returnedFeature.properties.NAME + "</b><br />" + returnedFeature.properties.ADDRESS,
                      null,
                      true
                    ));

I have the webmap up and all of the layers and basemap are rendering ok but when I click on a feature the cursor just spins and spins with no end. I can still navigate on the map and pan around, zoom in and out, but as soon as I stop navigating the spinning cursor resumes and a pop up never generates. I'm a complete nube to web mapping. Tried looking at a few other posts with pop up issues but couldn't see the same cause.

  • 1
    Does the WMSGetFeatureInfo work and receiving data? Hint: perform a manual getFeatureInfo request or check your Browsers Developer Tools Network tab and check the activity after clicking a feature. – bennos Jun 22 '17 at 6:10
0

The tiles making the baselayer were stored in a file folder in my docs. It was able to render but nothing would come back because of a mismatch from what was on local host and the location of the tiles. I put the files into the same folder as the webroot for local host (C:\Program Files (x86)\GeoServer 2.10.3\webapps\site_folder\tiles) and it worked like a charm.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.