I am a new QGIS user and I am curious about how slowly it is performing; it is possible that I'm asking more of it than I think I am. Here's what I think is the relevant information for assessing whether it's performance is unusually slow.

QGIS version 1.74 GDAL/OGR version 1.9.0 PostgreSQL client version 9.1.2 QWT version 4.8.0

Project info: 1 vector layer of polygons queried from a remote PostGIS database (query is simple and very fast) returning 160 total rows all in the project's defined coordinate space (WGS 84) and spanning the globe. The PostgreSQL table containing those rows occupies less than 130 kb of disk space, and the queried rows comprise pretty much the entire table.

System: MacBook OS X 10.7.3, 2.4GHz Intel Core Duo, 4GB RAM.

Performance: Rendering takes 5-10 minutes. In fact, any change takes nearly that long, including renaming the single layer; that really surprised me. No other memory-hungry applications are running concurrently.

This is frustrating because any modification of the project, however slight, requires a lengthy wait before the results can be assessed, and sometimes the application simply crashes without completing whatever I asked. Is this unusual?


I have Shapefiles of the same data. They are 45 files totaling about 100 MB. That figure is clearly discrepant with the size of the data set I described in my original post and it makes the slowness more understandable.


I just discovered the "Render" button at the bottom left of the QGIS map viewer. I feel like a bit of an idiot for not having noticed it before, but turning off rendering greatly increases the speed with which I can accomplish tasks for which immediate re-rendering isn't critical. I mention this here for the benefit of other new users.

  • 1
    This does sound unusual - QGIS usually performs very well compared to other GIS systems. I'd suspect some sort of delay with the remote database, though it sounds like a small set of data. What other data do you have loaded?
    – Simbamangu
    Commented May 1, 2012 at 13:56
  • 1
    Do you get the same problem with other data layers or is it just this one in particular? If so, I wonder if there is some invalid geometry in your data, or even a large amount of null geometry. Commented May 1, 2012 at 14:30
  • Could this be the labelling issue? It might be worth rendering the layer without labels to see if this makes a difference.
    – nhopton
    Commented May 1, 2012 at 14:38
  • I noticed that QGIS 1.7.4 connecting locally to my PostGIS 2.0 database is extremely slow on my powerful windows computer, but it works speedily on my much slower Mac(OSX). I haven't figure out what the problem is either.....
    – djq
    Commented May 2, 2012 at 0:00
  • Assuming there are always going to be factors that make the rendering slower or faster, I think the best scenario is to move to a background rendering thread that doesn't lock up the whole application while it's working. I love QGIS. It is very stable, but it can take several minutes to re-render the view and it just blanks out the whole lot and redraws it completely. All my layers are file-based and can be up to 1 GB per map (the majority of this is large GeoTiff relief backgrounds). This is probably always going to be slow, but QGIS could put the rendering into a separate thread, and make it
    – user9907
    Commented Sep 1, 2012 at 3:41

5 Answers 5


My installation of QGIS gets way faster and more responsive when I close the browser window. I had QGIS 3.6.2 and switched to 3.4.7 LTR. Both were very unresponsive until I closed the browser window. Use Menu View - Panels - Browser to show it again.

  • Here is the github bug report for this issue that goes into more details, future readers should be able to check if it's been fixed yet (not yet as of December 2020): github.com/qgis/QGIS/issues/33778
    – Scott
    Commented Dec 29, 2020 at 20:42
  • I’ll add that this appears to be caused by QGIS repeatedly trying to access a disk drive that is not available. This could be a network drive, or a local drive that is assigned a letter but not actually accessible. If you still want to use the file browser, follow the directions here to hide just that drive: github.com/qgis/QGIS/issues/33164#issuecomment-708651902
    – Scott
    Commented Jun 8, 2021 at 23:50
  • This issue has been fixed in QGIS 3.20.
    – Scott
    Commented Jun 11, 2021 at 23:55

Short answer: No.

Its hard to offer specifics but:

It sounds like you have some major performance issues going on there but its probably not hardware. My first suggestion would be to test the database, but you've already done that.

You may wish to try a different Open Source GIS, there are lots out there (many listed here: What are some Free and Open Source GIS Desktop packages), but the obvious one would be gvSIG. If whatever you use has the same speed/performance issues then the problem is database side.

You may also want to try exporting the data to a SpatiaLite database and loading from that.

Also, if you want to stick to QGIS, try uninstalling it and using a different version.


my guess is that you have some locking issue in the database. If renaming the table takes time it is not because the renaming takes time but the db waits for something. Have you tried restarting the db?

  • It's not a database issue. I've tried loading the shapefiles locally and it's just as bad.
    – Gregory
    Commented May 1, 2012 at 14:09
  • 3
    @pyrogerg - Any chance you could post the shapefiles?
    – Simbamangu
    Commented May 1, 2012 at 14:50
  • 1
    @Simbamangu - I don't think I can post them all; they are 45 files totaling about 100 MB. That figure is clearly discrepant with the size of the data set I described in my original post and it makes the slowness more understandable.
    – Gregory
    Commented May 1, 2012 at 18:21
  • @pyrogerg In my experience, it helps if you zoom into a smaller area before loading datasets of that size from PostGIS. You can use an OpenLayers layer or any other dataset that is available to you to locate a suitable area.
    – underdark
    Commented May 1, 2012 at 23:11
  • @underdark - Thanks for the suggestion; I'll try that next time. I had intended the 45 shapefiles I loaded to be an initial test of visualizing a far larger dataset, but I don't think my computer can handle much more than this!
    – Gregory
    Commented May 2, 2012 at 0:51

I find that things I do at work on ArcGIS run really slowly with data from our database which is 1800km away, but runs really quickly on QGIS at home, so I would look at the network and remote database side first, QGIS seems to run most operations at the same speed or faster then ArcGIS, most of the time,

  • I had a issue with arcgis once where it downloaded all the data for the map to the local computer first before doing anything, and since it was 2 or 3 GBs of data it shut our network down for about half a day....IT dept wasn't very happy, but maybe QGIS is doing something similar
    – Banger
    Commented May 2, 2012 at 3:50

Qgis simply works "ok", unless you have any of this situations:

a) the layer is big.. for some process the meaning of "big" may vary from 10mb to 250mb..

b) the layer have large multipart features (features made of "too many" parts)

c) the layer have some (non multipart) features with "a lot of vertex/nodes"

.. for example. "cliping" or "dissolve" for me usually Qgis dont do it or just crashes.. or in some cases take like 36 times to accomplish a task..compared to the same task (same shapes/layers perform the same process) in ArcGis.. example.. a 6hs dissolve process on a 1330000 features layer (entire country..like half of united states) on Qgis on a new intel i5+8Gb ram + Ubuntu..that maybe also can crash in anytime.. compared to dissolve the very same layer on arcgis on an 10 years old notebook(core duo)+2Gb ram+ windows XP..that make it correctly on 10 minutes.

or cliping that dont perform on any "very complex" feature of the base layer..so the result its a clip layer that never perfomed the clip on a polygon so the clip have missed 30% of the area.. so usually first I try to do it with QGis..and then, if not worked.. take the shapes to my very old notebook and have the work done in a simple an fast way.. Qgis tend to run better under windows environment.. but the "layer size" issue is very common there too.. (Im using GIS since 1995.. from arcview 3.0 to arcgis 10.2, and from 2003 using Qgis..under windows and now under ubuntu(at work) )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.