The ArcGIS SpatialJoin online help page has a long list of match_options when joining data spatially, including HAVE_THEIR_CENTER_IN.

However running the arcpy.SpatialJoin_analysis tool in Python with this option results in an error:

ExecuteError: Failed to execute. Parameters are not valid.
ERROR 000800: The value is not a member of INTERSECT | CONTAINS | WITHIN | CLOSEST.
Failed to execute (SpatialJoin).

These options are also missing from ArcToolBox:

enter image description here

The licensing on the help page suggests this tool is available for all versions of ArcGIS:

ArcView: Yes ArcEditor: Yes ArcInfo: Yes

So is this an error in the docs, licensing on keywords, or a misunderstanding on my part?

  • 1
    Just looked in my version of ArcGIS 10 (SP3). I have an ArcEditor Licence on the machine I'm using at the moment and I DO have the HAVE_THEIR_CENTER_IN in option in ArcToolBox. So, this isn't an answer, but it does prove that it is NOT a misunderstanding of the documentation on your part and that something else must be awry. It wouldn't be a Service Pack issue would it? May 1, 2012 at 14:15
  • Can you post your script? Maybe you have your parameters out of order. The Match Option should be the 7th argument. "HAVE_THEIR_CENTER_IN" is a valid match option.
    – klewis
    May 1, 2012 at 14:21
  • @klewis - I tried both with named arguments, and the full 7 parameters - same result. The error message indicates it is the correct parameter, but not a valid option. May 1, 2012 at 14:25
  • @sylvester - will look at updating service packs, I fear it is a license limitation (using ArcView at the moment) May 1, 2012 at 14:26
  • 1
    Using ArcGIS 10 SP3, I see a "HAVE_THEIR_CENTER_IN" with the ArcView license level and when I run it I don't get an error. May 1, 2012 at 14:27

2 Answers 2


Looking at the list of fixes in SP3 it appears it was an error and has been fixed:

NIM070795 - Spatial Join tool not ignoring invalid match options.

I installed the service pack, and now all options are present in the ArcToolbox tool, and my script runs without problems.

Thanks to @sylvester for the suggestion.


A similar question has been asked with ERROR 000800 before and it looks like it wasn't a licensing error then. The previous question - ERROR 000800 when trying to snap points layer to line or buffer layer - so the problem is most likely an error with your script though you'll have to give us more specifics of the script if you want specific feedback.

There's also a ESRI thread here: The value is not a member of %s

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.