1

I am copying some records in a attribute table from layer1 and pasting those as new objects in layer2.

The first time I copied some records/objects from the attribute table of layer1, I pasted them as a new vector layer (it is layer2) When I copy/paste a new record/object in layer2, it is visible as a new record in the attribute table of layer2, but it is not visible on the map/canvas (although the first copied objects are visible).

See the following screenshots (attribute table with 6 features/polygons and canvas with only 5 polygons)

6 attributes/polygons, one without area surface Canvas with no more then 5 polygons

  • Hello, are you working with shapefiles? those seem to be a little fragile while editing. if you have successfully pasted some features, save the shapefile again or even save it as a new shapefile. also, are all features you are dealing with in the same projection? – DirkB. Jun 23 '17 at 21:57
  • Yes, I am working with shapefiles. They are in the same projection Belgian Lambert 72 EPSG: 31370 – Boswachter_Marc Jun 23 '17 at 21:59
  • I just saved it as a new shapefile. The object is in the attribute table but doesn't show up on the map/canvas... – Boswachter_Marc Jun 23 '17 at 22:05
  • Can you support your question with screenshots or even the new shapefile? What kind of shapefile do you have? Point, Line, Polygon? – DirkB. Jun 23 '17 at 22:08
  • The shape file is a polygon – Boswachter_Marc Jun 23 '17 at 22:11
1

To copy features from one shapefile to another you select features from shapefile a and use copy. next step is to activate edit mode in your aimed shapefile b. you can open the attribut table enter image description here

next it should look like this enter image description here

to check everything went fine, add an area row and calculate the area to make sure there is a geometry addedenter image description here

  • Thank you Dirk. I just copied to shapefile B and added the column Area. Something is wrong with the geometry. Some have a area, others do not. Strange, because in shapefile A, all the records have areas... – Boswachter_Marc Jun 23 '17 at 23:13
  • Going to sleep now ;-) – Boswachter_Marc Jun 23 '17 at 23:16
  • +1 for suggesting $area to double-check the outcome... btw isn't it better to set its Type as Real (decimal number), perhaps? – Kazuhito Jun 23 '17 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.