3

When I try to add a WFS-layer in QGIS, it crashed automatically. It generates a .dmp file, which I opened in Notepad++, but I don't know where to look for the actual cause of the crash.

Tried various WFS-links, all crash. Tried various options (change CRS, zooming to certain area, "only request features overlapping the view extent", using different titles of the same WFS-server... etc...

Some of the WFS links I've used:

https://services.geodan.nl/public/data/org/gws/MBIZ4280LEEF/MBIZ4280LEEF/wfs?

//geodata.nationaalgeoregister.nl/rwsgeluidskaarten/wfs?request=GetCapabilities

//geodata.nationaalgeoregister.nl/bag/wfs?request=GetCapabilities

Any ideas on what the problem might be?

Windows 10, 64-bit QGIS Desktop 2.18.8

  • I tried the first link provided and can't reproduce your error. The WFS loads just fine.: Windows 10 64bit QGIS 2.14.15. So is it an option to "downgrade" QGIS? – LaughU Jun 26 '17 at 8:15
  • Thanks for the "downgrade"-tip. I also have version 2.16 installed and it worked with this older version. – Iglias67 Jun 26 '17 at 13:31
2

This doesn't solve the problem itself but allows you to continue your work. It could be a bug.

Workaround:

  • If you can choose which version you use, try Version 2.14 or 2.16.
  • You can load the WFS with the functions QGIS provides.
  • It seems to be a bug in version 2.18.8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.