0

I have GeoServer on Ubuntu 14 as part of a Geonode 2.6 install. I am having trouble installing the GDAL extensions. The version of GeoServer says 2.9-SNAPSHOT.

I have tried to install the GDAL extensions following the instructions here - http://docs.geoserver.org/2.9.3/user/data/raster/gdal.html

I used the GeoServer 2.9.4 GDAL extensions. After restarting GeoServer, the additional coverage formats aren't available.

gdalinfo --version returns the correct version, and gdalinfo --formats returns the list of supported formats.

I can't find anything obvious in the log file, there is a reference to - ArcSDE Java API seems to not be on your classpath. Please verify that all needed jars are. ArcSDE data stores will not be available.

and then

2017-06-27 03:31:35,393 DEBUG [gdal.envihdr] - EnviHdrFormatFactory is not availaible. 2017-06-27 03:31:35,393 DEBUG [gdal.jp2mrisd] - JP2MrSIDFormatFactory is not availaible. 2017-06-27 03:31:35,393 DEBUG [gdal.jp2ecw] - JP2ECWFormatFactory is not availaible. 2017-06-27 03:31:35,393 DEBUG [gdal.mrsid] - MrSIDFormatFactory is not availaible. ...........etc

I have updated the \etc\environment file to include the path, still nothing.

  • 1
    Versions have to match. So you need extensions from a 2.9-SNAPSHOT (ideally the same 2.9-SNAPSHOT). 2.9.4 is not close enough. – BradHards Jun 27 '17 at 4:50
  • and it should be the snapshot from the day you downloaded the server war – Ian Turton Jun 27 '17 at 8:09
1

Maybe you can download gdal-plugin from bondlessgeo site. Also you can learn how to install it form here

Have a nice day.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.