1

I got shape files in WGS84 and need to project it to British_National_Grid (27700) I used QGIS to save them as a new shp file with ESPG:27700

Throwing the shape files into ArcMap with the Data frame Coordinate System set to British_National_Grid WKID: 27700 Authority: EPSG

When I try to edit the shape files I get a warning that the data is in a different coordinate system than the dataframe.

I was expecting both to be in 27700? Do they use different transformation paramenters to do the transformation which ArcMap catch or why do I get this warning?

  • 3
    Projections in shapefiles are defined by the Well Known Text that is stored into the .prj file. ESRI is using a bit different dialect and QGIS may not understand that both .prj files mean the same. You can make a test by renaming your .prj from QGIS and using that instead of the one from ESRI. Add also the contents of both .prj files into your question. – user30184 Jun 28 '17 at 12:02
  • You are right, that made it work properly. Thanks! – geogrow Jun 28 '17 at 13:25
4

For most of the world EPSG:27700 is defined as:

PROJCS["OSGB 1936 / British National Grid",GEOGCS["OSGB 1936",DATUM["OSGB_1936",SPHEROID["Airy 1830",6377563.396,299.3249646,AUTHORITY["EPSG","7001"]],TOWGS84[446.448,-125.157,542.06,0.15,0.247,0.842,-20.489],AUTHORITY["EPSG","6277"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4277"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",49],PARAMETER["central_meridian",-2],PARAMETER["scale_factor",0.9996012717],PARAMETER["false_easting",400000],PARAMETER["false_northing",-100000],UNIT["metre",1,AUTHORITY["EPSG","9001"]],AXIS["Easting",EAST],AXIS["Northing",NORTH],AUTHORITY["EPSG","27700"]]

while for ESRI it is defined as:

PROJCS["OSGB_1936_British_National_Grid",GEOGCS["GCS_OSGB 1936",DATUM["D_OSGB_1936",SPHEROID["Airy_1830",6377563.396,299.3249646]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",49],PARAMETER["central_meridian",-2],PARAMETER["scale_factor",0.9996012717],PARAMETER["false_easting",400000],PARAMETER["false_northing",-100000],UNIT["Meter",1]]

Copy the second one into your shapefile's .prj file to make ESRI recognise it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.