4

I'm currently working on a map for the different brazilian biomes.

Here's the map on the standard QGIS view I have to label them and show it on my final map, but when I'm working on the composer, this happens:

Nope, I didn't crop it wrong.

That's the exact size of my map. If you take a close look, you'll see that the "CERRADO" word appears cut in the middle on the upper- left side. I've looked around and found a pretty similar situation here but the solution proposed doesn't apply. It still displays like the second picture. I need all three labels to be inside the map window I created on the composer. Any thoughts?

  • Is the map rotated? – ndawson Jun 29 '17 at 5:52
  • Yes, it is. I have this map and other two (the squares on the image above) which are also rotated. – Eric Lino Jun 29 '17 at 14:14
  • 3
    Ok. Unfortunately the option to prevent cut-off labels doesn't play nicely with rotated maps (in other words - it doesn't work at all!). I've hit this same issue on maps I've created. – ndawson Jun 29 '17 at 22:52
1

You can try this settings in your labelling options.

enter image description here

Or perhaps, you could check the map canvass and composer have the same rotation.

|improve this answer|||||
  • My labels have the exact same settings since I posted this question (I'll add a picture there) and no rotation has been applied to the labels. If I do so, they appear rotated on the final map, which is not what I desire. – Eric Lino Jun 29 '17 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.