4

I have LAS data obtained from 2014 NCFMP Lidar: Statewide North Carolina (Phase 2). I've created LAS dataset in ArcGIS and was trying to extract building footprints using LAS to Raster tool (I filtered classification codes first). However, when I ran the tool it displayed an error 'ERROR 999999: Error executing function. No spatial reference exists.' I've looked at metadata and horizontal coordinate system seems to be correct while vertical should be NAD83(2011) Ellipsoid (meters) and in properties of my LAS dataset it displays as Custom NAVD88 height. I reassigned to NAD83, but it didn't change anything and I'm not sure how to fix it otherwise.

I also opened my data in ERDAS Imagine to double check, and, indeed, elevation information was shown as undefined.

I'm new to LiDAR.

I've attached screenshots in case it'll be helpful.

Metadata from 2014 NCFMP Lidar:

Process Description: Data were received by the NOAA Office for Coastal Management from the North Carolina Flood Mapping Program in the form described above. It was ingested into the Digital Coast Data Access Viewer system for distribution by:
1) reprojecting to geographic coordinates with vertical meters
2) transforming the vertical datum to NAD83 ellipsoid heights using the NGS GEOID12a model
3) compressing the data using laszip (LAStools version 150828) to LAZ format.

Process Date: 201509
Direct Spatial Reference Method: Point

*Spatial Reference Information:    
**Horizontal Coordinate System Definition:**

Geographic: 
Latitude Resolution: 0.0000001
Longitude Resolution: 0.000001
Geographic Coordinate Units: Decimal degrees
Geodetic Model:
Horizontal Datum Name: NAD83 (2011)
Ellipsoid Name: Geodetic Reference System 80
Semi-major Axis: 6378137.000000
Denominator of Flattening Ratio: 298.257222

**Vertical Coordinate System Definition:**
Altitude System Definition:
Altitude Datum Name: NAD83(2011) Ellipsoid
Altitude Resolution: 0.001
Altitude Units: Meters
Altitude Encoding Method: Explicit elevation coordinate included with horizontal coordinates

enter image description hereenter image description here

  • "I reassigned to NAD83, but it didn't change anything..." Can you elaborate on this? How did you reassign the coordinate system? What steps did you take? The problem almost certainly has to do with defining the coordinate system. – J.W. Powell Jun 30 '17 at 16:53
  • Hi, thanks for the answer! Yes, I totally agree with that, the problem is with coordinate system. I changed coordinate system in properties of LAS dataset, I guess 'reassigned' was not a proper word. I've done a bit of search later and it seems like it's not possible to re-project LAS files using ArcGIS. I also came across that post gis.stackexchange.com/questions/242347/… which is relevant to my issue, but I guess I couldn't 'reassign' it properly. – Ann K. Jun 30 '17 at 18:13
  • Rather than changing the projection in 'Properties,' try using the 'Define Projection (Data Management)' tool on the layer. I can't be sure this will work without actually having a copy of your data. But I've done this on LIDAR data that lacked a coordinate system. – J.W. Powell Jun 30 '17 at 18:43
  • Thanks a lot for a tip! I did try 'Define Projection' tool, but the data already has coordinate system 'GCS_North_American_1983 / VCS:NAVD88 height' that is not the same as in the metadata file. I ran the tool anyway out of curiosity and it didn't work unfortunately for me (and I can't use 'Project' tool). Do you have any other ideas what I can do in my situation? – Ann K. Jun 30 '17 at 19:44
  • 1
    Possible duplicate of LAS dataset to raster: 'no spatial reference exists'? – Andre Silva Jul 5 '17 at 22:41
2

The Metadata from 2014 NCFMP Lidar reports the next process step from the one you quoted as (emphasis mine):

The vertical values in this data set have been converted to reference North American Vertical Datum of 1988 (NAVD88), using the GEOID12B grids provided by the National Geodetic Survey. ... .

So, apparently it was converted back to NAVD88, and ArcGIS is reading it correctly?

That being said, from which source did you take the .las metadata information? From the coast.noaa.gov site or directly from the .las file (i.e., from its header and Variable Length Records - VLRs)? Be aware the correct way to do this is the latter method. Almost all LiDAR processing software will have a tool for this (e.g: LAStools is lasinfo; Fusion is Catalog; in ArcGIS is Las Dataset Properties).

Apart from above, I believe the error you got when trying to run Las Dataset to Raster is due to geographic coordinates (instead of projected ones) assigned to the .las file. See:

LAS dataset to raster: 'no spatial reference exists'?

Here are some GIS SE posts to help you out reprojecting LiDAR data:

3

Thanks a lot for the answers! Eventually, I resolved the issue:

My "sample size" setting for LAS Dataset to Raster tool was wrong - I should have used 0.00001 size (that is equal to 1 meter) since the original data is in degrees units. I got the tool working, but it didn't really help me to extract the values that I wanted to.

So, instead, I used GRASS GIS option r.in.lidar, first reprojecting .las files using las2las command in GRASS:

las2las --a_srs=EPSG:4269 --t_srs=EPSG:2264 --i 20140224_LA_37_20231301.las -o laspr.las --scale 1 1 1 

*data from this dataset needed to be rescaled in order to be projected, I used 1 meter scale.

Once I got all the tiles to have right projection, I ran r.in.lidar with class_filter set to buildings.

r.in.lidar -e -n --overwrite output=rast_veg file=C:\LasTiles\tiles_list.txt resolution=1 class_filter=6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.