3

Running Windows 7 Professional (64bit) SP1. I have QGIS 2.18.10 installed from the standalone installer. The GRASS commands (161 algorithms) are present in the toolbox and seem to run ok. However the GRASS GIS 7 commands (314 algorithms) result in the following message box:

enter image description here

I have tried uninstalling, deleting all traces of QGIS from the Registry, and then reinstalling using the OSGeo4W64 installer selecting various different options, including adding GRASS 6, also without any success. I deleted the OSGeo4W64 installation and reinstalled it. No change. I then re-installed the standalone QGIS package and copied the \msys folder from the OSGeo4W64 GRASS 6 installation into the \apps folder of the QGIS 2.18 directory. Nothing changed. I have ensured paths are correct in Providers section of Processing options:

enter image description here

I have ensured the output folder has no non-ASCII characters as that seems to be another possible cause, but still have not solved the issue.

  • BTW: Consider to not activate the outdated GRASS GIS 6. – markusN Jul 1 '17 at 7:43
  • I read somewhere that the Msys folder is required for GRASS 7 even though it doesn't ship with GRASS 7, but it does ship with GRASS 6. Hence the reason for adding GRASS 6 in the OSGeo4W64 install. but the GRASS 7 path in Processing options still points to the GRASS 7 installation, not GRASS 6. – reedmace Jul 1 '17 at 18:49
4

It works for me after installing from OSGeo4W64 setup, but not from the standalone install. The standalone GRASS GUI does crashes for me too, while the one from OSGEO4W64 works.

Once installed, you have to set the GRASS path in the processing options to C:\OSGeo4W64\apps\grass\grass-7.2.1. Then you can access GRASS7 modules from both, standalone and OSGEO4W64 QGIS. Apart from that, Grass 7.2.0 will work too if you have QGIS LTR still running.

Unfortunately, the GRASS plugin does not work either, and the workaround does not help on that.

See https://issues.qgis.org/issues/16777 fro progress on the issue.


UPDATE

The issue has now been fixed in the OSGEO4W setup. To get QGIS 2.18.10 standalone running too, you can copy C:\OSGeo4W64\bin\gdal201.dll to C:\Program Files\QGIS 2.18\bin.

  • I've tried the OSGeo4W64 setup. I have no problem accessing the GRASS 7 algorithms - they are all there. They just don't run, giving the error message box above. – reedmace Jul 1 '17 at 18:46
  • For me, it worked after changing the GRASS7 folder in the options to OSGEO4W64. – AndreJ Jul 1 '17 at 18:53
  • Just tried pointing the GRASS 7 path to the OSGeo4W64 GRASS 7 folder and it still gives the same error message box about not being installed. – reedmace Jul 1 '17 at 18:54
  • In fact GRASS6 commands give the same error message box now (but for GRASS not GRASS7). – reedmace Jul 1 '17 at 18:59
  • 1
    The GRASS plugin does not work either for me. We have to wait for a bugfix. I suggest to roll back to QGIS 2.18.9 meanwhile. – AndreJ Jul 3 '17 at 9:24
-1

Delete Msys' path, sometimes in windows makes some errors... really don't know why, but it's work for me

  • I tried this but still no joy. – reedmace Jul 1 '17 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.