1

I use the version on web("http://www.kyngchaos.com/software/qgis"). Whether I come to install QGIS 2.18.9-1 or QGIS 2.14.15-1, I click on the QuantumGIS.pkg and it opens the install dialogue box but with a warning "The GDAL 2.1 framework is required."

Could anyone give me a clue how to properly install QGIS on Mac? The version is Mac OS Sierra 10.12.5.

  • I can't also install QGIS. I installed the three others in order but when I try opening the QGIS package, the installation box won't open. I'm using macOS Sierra. – user106355 Sep 28 '17 at 13:54
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Evil Genius Sep 28 '17 at 14:28
3

Have you read the Read Me.rtf file ?

This distribution requires my GDAL Complete 2.1 framework package, and the Matplotlib and NumPy python modules. These are included on the QGIS disk image.

enter image description here

The installation order is

  1. GDAL Complete.pkg (GDAL 2.1 framework installed in /Library/Frameworks/GDAL.framework)
  2. Numpy package (Python module installed in /Library/Python/2.7/site-packages)
  3. matplotlib package (Python module installed in /Library/Python/2.7/site-packages))
  4. and finally the QGIS package (Application /Applications/QGIS.app)
0

You can try NextGIS QGIS network installer. Some details about this QGIS build can be found here: http://nextgis.com/nextgis-qgis/

and here: http://nextgis.com/blog/qgis17/

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.