0

ArcGIS (10.3) Export to PDF fails (text fonts show up as cryptic symbols - unreadable).

When exporting to JPEG, TIFF or PNG, the fonts show up correctly. This is after ArcGIS new installation, it worked fine on the old desktop PC. Now Windows 10, on notebook. Same configuration works fine on all colleagues PCs. It looks OK When I use "print" (with PDF creator) instead of "export" from within ArcGIS.

Any suggestion why export cannot provide maps with correct fonts?

  • Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format. – Midavalo Jul 3 '17 at 14:26
  • thanks - but we have tried all options, couldn't get it right in the exported PDF. Even compared with other users (were it works ok.), just to see if we are using different settings. – Joachim Haupt Jul 4 '17 at 7:06
4

In ArcMap you can embed document fonts into your exported PDF file.

In the "Export Map" dialog, expand "Options", click on Format tab, and check the option "Embed All Document Fonts"

enter image description here

  • thanks , we tried embeded fonts, doublechecked all options, but nothing changed. Since the export to image formats works fine, I guess that this is nothing within ArcMap, but perhaps a missing Font on windows or PDF (Adobe) ? – Joachim Haupt Jul 4 '17 at 7:02
0

What do you use for decimal separator ( point or comma ) ? Try this patch : https://support.esri.com/en/download/2183 ESRI's explanation : This patch addresses an issue with labels in PDF export in non-US locales using a decimal separator other than a period

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.