1

This question already has an answer here:

New question branching off from Geometry Errors with Imported Shapefile, Unable to Fix

I attempted to buffer datapoints to convert them into many small polygons (so it will be acceptable .shp polygon format for Excel 2016 Power Maps)

Here are the steps .... why isn't it working?

1. Add vector layer

enter image description here

2. Select .shp file

enter image description here

3. Select Fixed Distance Buffer

enter image description here

4. Change distance from 10 to 100

enter image description here

5. After it's completed running I get a big green screen. Not sure what to do next

enter image description here

marked as duplicate by underdark qgis Feb 22 at 9:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

You have a WGS84 shapefile (EPSG 4326) which is units of degrees. You're buffering by 100 degrees, which covers about half of the earth!

So you can do two things. One option is to go back to your original CSV or shapefile that's still in the New York State projection, buffer that by a however many feet you think will work for what you're trying to do. Let's say that's 5 feet radius. Then you can reproject your circles to WGS84.

Or you can buffer the WGS 84 points by the right amount of degrees. 5 feet at the latitude of New York City is about 0.000015 degrees.

  • Ok, I'll try this – Rhonda Jul 5 '17 at 0:08
  • This does work. Now muddling through "Duplicate Name Errors" with Excel, but for all intents and purposes this works. Thank you! – Rhonda Jul 5 '17 at 14:36
3

I think this may be an issue with your projection (CRS). The distance in the fixed buffer prompt references the units of your projection. To fix this you need to go to the properties of the shapefile and either change the projection, or finds out what your units are.

Not the answer you're looking for? Browse other questions tagged or ask your own question.