I'm dealing for the first time with an ArcSDE geodatabase so I'm facing simple problems to you. ESRI help wasn't of much help (to a begginer at least).

I can't edit my data in ArcMap, most probably because I've already ""registered as versioned" my featuredataset. I did use "Unregister as versioned" from ArcCatalog, but still can't edit my data. And then I got some "schema lock error"" :) So any clues?

Ps: I'm the only user of the geodatabase.

Thank you very much, Ligia

  • I believe you need either ArcEditor or ArcInfo license level to edit a ArcSDE GDB. May 3 '12 at 10:15
  • 4
    Do you have a map service using the SDE database?
    – artwork21
    May 3 '12 at 11:33
  • I have an ArcEditor licence. and I do have a map sevice using the database. I will try to stop the map service and see what happens. thanks.
    – Ligia
    May 3 '12 at 12:36

You can edit non versioned data too. In Editor Options dialog, select Versioning tab and unchec "Edit a version..." checkbox. Then start editing.

  • thanks. But apparently I still cannot edit my features.
    – Ligia
    May 3 '12 at 8:41
  • While starting an editing session, my features are not available as targets. So I tried to Register my Data as Versioned, and apparently I can't because there's a lock: "Failed to register as versioned. Lock request conflicts with an established lock [DBO DBO DBO]". ps: the featuredataset I'm trying to version contain non simple data (a geometric network). Tried to delete it. Can't. Same message as above.
    – Ligia
    May 3 '12 at 9:28

Apparently I wasn't able to "register as versioned" my feature dataset because I had a map service which was using the database. Stopped the map service, and everything works fine. Artwork21 you were right.

Thank you all for your help.


have you set permissions to edit? you need to go into ArcCatalog and right click on the Database or each dataset and select permissions. Or you can use another database manager if you have one and make sure you are in the editing group or your username has permissions to edit,

  • there are 4 users, I am the Administrator, and apparently I have "Higher-lever permissions" and cannot check any of the three options and "cannot apply. the table is already locked".
    – Ligia
    May 3 '12 at 9:57
  • we sometimes also have a problem where people have logged out of Arcmap but the database doesn't recognise this and says they are still logged into the database and that it is locked, at this point we have found it's easier to restart the server with the database on it. But I'm not sure if that is your problem as it seems to be saying you have 3 instances of the DBO operating, try closing the arcmap window first so that you only have arc catalog open
    – Banger
    May 3 '12 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.