I'm using Quantum GIS Ver. 1.7.4. I have upgraded openlayers plugin 0.7 to 0.9. However when I open google satellite, a watermarks/copyright dialog box "Data Peta@2012 ..." appear in the middle of the screen. The close dialog box sign (X) appear on the top right of the dialog box but not active:

enter image description here

How can I close the dialog box?


  • I run Quantum GIS using windows. – Mohd Ali May 4 '12 at 3:29
  • We are having this issue on our PCs. We are running Win7, QGIS 1.7.4 and .9 of the Openlayer extension. – user7586 May 17 '12 at 5:32
  • Same problem here. Worked fine yesterday now I have this white box in the center of my map with copyright info and it just wont go away. I'm working off the QGIS Master on an XP machine. Uninstalled/reinstalled twice, rebooted, and reset connection to the web. help! (I know this is not an answer, first time post to this forum, so I'm not sure how to add it to the above comments) – Carlos da Ponte May 17 '12 at 16:55
  • Same problem here too. Don't know how to remove it. I use the OCM landscape layer instead. Hope that help! Doum – Doum May 17 '12 at 17:16
  • I now see it too, after zooming in from global view. I added a screenshot. – underdark May 17 '12 at 18:05

EDIT (May 21): This has been fixed with version 0.91 of the plugin.

Previous answer...

This has been discussed recently here: https://gis.stackexchange.com/a/20608/6725

As per the suggestion there, you can edit the Open Layers plugin to hide the white box.

Edit [path to your user plugins]\openlayers\html\google.css

  • Linux and other unices: /home/$USERNAME/.qgis/python/plugins/
  • Mac OS X: /Users/$USERNAME/.qgis/python/plugins/
  • Windows: C:\Documents and Settings\$USERNAME.qgis\python\plugins\
/* Add this to end of file */
.olLayerGooglePoweredBy.olLayerGoogleV3.gmnoprint {

Restart QGIS to see change. Until OpenLayers's javascript is updated and the plugin author can subsequently upgrade the plugin, it may remain broken. The HTML files for the map renderings already note a Google Maps API of 3.3, so it's not an issue of a missing API version.

This has been reported as an issue in the plugin's tracker. I will reference this page in the tracker.


You can't.

I'm seeing the same issue since yesterday, with QGIS 1.7.4 and Open Layers Plugin 0.9 on Linux. I had those versions installed for a while already, and they used to not display the watermark.

Maybe Google recently changed their backend and the tiles they send to the plugin.

  • Open Layers Plugin 0.91 fixes the issue. – François May 21 '12 at 20:07

OpenLayers has resolved this issue. see: http://trac.osgeo.org/openlayers/ticket/2984

  • Thanks, I've forwarded the link to the QGIS mailing list. Hope they can use the fix too. – underdark May 18 '12 at 10:56
  • 1
    Drop this OpenLayers.js into the .qgis\python\plugins\openlayers\html directory. It's OpenLayers 2.11 with the Google/v3.js patch. Works on QGIS 1.74/1.80 and OpenLayers Plugin 0.90. – Jerry May 19 '12 at 0:28
  • I really appreciate the help, but unfortunately I am a very new user who needs the most basic QGiS for dummies. I gather this is something I should be doing through the Terminal utility? Can someone tell me what exactly I should be typing in order to "Drop this OpenLayers.js into the .qgis\python\plugins\openlayers\html directory"? I'm guessing it's something along the lines of what dakcarto has posted? I am a very new user, trying to construct very basic maps. Would love to use Open Layers and am grateful your help. Thanks. – Caroline T. Schroeder May 19 '12 at 11:09
  • Caroline, Close QGIS if it is open. Click on "this" above to download the file "OpenLayers.js" to the directory (I'm assuming that Windows 7 is your Operating system) C:\Users\<yourusername>\.qgis\python\plugins\openlayers\html replacing the OpenLayers.js already there. – Jerry May 20 '12 at 4:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.