0

I regularly use land registry data from https://www.gov.uk/government/collections/download-inspire-index-polygons however at present the .gml, when adding a vector layer, renders points and not polygons (as it usually does). Could anyone advise how this could be rectified?

  • what GIS software are you using? how are you styling the data? can you add a snippet of the problematic data to your question – Ian Turton Jul 5 '17 at 15:09
  • I'm using QGIS 2.18.5. It'll only generate the points from the .gml and not the polygons. – Neil Harvie Jul 5 '17 at 15:16
1

It seems that the Land Registry have broken the link back to their schemas so that OGR (and hence QGIS) can't parse the GML and have to guess.

You can over rule this initial guess by editing your .gfs file (in the same folder as the .gml file after you try opening it) to have these lines at the top.

<GMLFeatureClassList>
  <GMLFeatureClass>
    <Name>PREDEFINED</Name>
    <ElementPath>PREDEFINED</ElementPath>
    <GeomPropertyDefn>
    <Name>geometry</Name>
      <ElementPath>GEOMETRY</ElementPath>
      <Type>MultiPolygon</Type></GeomPropertyDefn>
    <GeomPropertyDefn>
      <Name>ReferencePoint</Name>
      <ElementPath>REFERENCEPOINT</ElementPath>
      <Type>Point</Type>
    </GeomPropertyDefn>
    <SRSName>urn:ogc:def:crs:EPSG::27700</SRSName>
  • Thank you Ian, that's perfect. I wonder if they'll change it again to confuse me or, even, for the better! – Neil Harvie Jul 5 '17 at 16:10
  • currently they seem to point to - 192.168.4.121:8080/geoserver/schemas/wfs/2.0/wf s.xsd so someone forgot to set the geoserver proxy url setting – Ian Turton Jul 5 '17 at 16:12
  • @NeilHarvie - if this answers your problem please accept the answer by clicking on the tick next to it – Ian Turton Jul 5 '17 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.