4

I have built several applications that use the ArcGIS JS API and secured services via ArcGIS Server. All of the apps have the same process of generating tokens on the server ( via php request ) and passed to the client where it is appended to the service urls. Recently we have noticed an issue when we attempt to upload an attachment. When the addattachment method is called the request is sent to the login page for ArcGIS Server. It appears that the request is not honoring the token.

Anyone run into this issue before? I have tried a proxy and esrirequest to modify the request but still doesn't work. I have also signed into ArcGIS Server and was able to upload an attachment through the GUI form there so the service is working.

  • Welcome to GIS SE. As a new user, please take the Tour. It's impossible to determine what is wrong if you don't provide code and some diagnostics of what your HTTP traffic looks like. Please Edit the question. – Vince Jul 6 '17 at 2:23
  • @Booshwa, what has changed on the server recently? Did you federate with ArcGIS Portal? Has the machine been assigned a DNS alias? Did the Feature Service Url in the application change? Did you change authentication (assuming you have a web adaptor installed)? – Don Jul 6 '17 at 16:26
  • We have implemented SSL which is the only thing that has changed. The service has been in use for a couple years and I have tested by uploading files through the feature service in ArcGIS Server (through the web adapter) We haven't changed anything on ArcGIS in several months. – Booshwa Jul 6 '17 at 17:37
  • I'll post as much as I can from the network panel and fiddler but I cannot share the app or the service URL as soon as I can. I can post some code but it's just the featurelayer calling the 'addattachment' method. Nothing custom there. – Booshwa Jul 6 '17 at 17:38
  • If you are using the php proxy from github.com/Esri/resource-proxy, there are a few open related issues reported in the github repo - github.com/Esri/resource-proxy/…. Including an open pull request: github.com/Esri/resource-proxy/pull/365 - does it work if you try that code? – Bjorn Svensson Jul 15 '17 at 0:27
1

This should be resolved now that https://github.com/Esri/resource-proxy/pull/365 has been merged.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.