I have Ubuntu 16.04 with postgresql 9.6 postgis 2.3 QGIS 2.18 installed.
I am trying to install
mapview (R library) with no success because of sf defencency.
I had this output:
configure: GDAL: 1.11.3 checking GDAL version >= 2.0.0... no configure: error: sf is not compatible with GDAL versions below 2.0.0 ERROR: configuration failed for package ‘sf’ * removing ‘/usr/local/lib/R/site-library/sf’
and this is what happened on the terminal:
$gdalinfo --version GDAL 2.1.0, released 2016/04/25 $ gdal-config --version 1.11.3
I am wondering the following questions:
Which is the difference between
Why does R say me that I have a
GDAL version less than
2.0.0 even if output of
gdalinfo --version is
How can I upgrade Gdal-config to one >= 2.0.0?
If I upgrade, will I have problem with postgresql, postgis Qgis or some other python module that use