2

I've been following along with this Ansible Playbook to get PostGIS Tiger data setup:

https://github.com/enigma-io/ansible-tiger-geocoder-playbook

Everything worked great, and it said everything was setup correct with no error messages. The only thing is that it took about 1 hour, instead of the 20-24 hours it said it normally should take (only about 5GB is being used on my volume instead of the 110GB or so it normally does)

So now i'm a bit unsure how to move on - I assume it didn't download all the data I needed (I even checked the config and all the states are set to download).

is there a command I can run or way to proceed to grab all of the tiger geodata/census tracts for each state? 5GB is definitely not enough, right?

Any ideas/help/suggestions?

1

I assume you used the Ansible playbook to both install PostGIS and load tiger data and that's why you didn't just use the script approach detailed in docs:

http://postgis.net/docs/manual-2.3/postgis_installation.html#install_tiger_geocoder_extension

It might be the census site blocked your downloads, as they seem to be doing that lately if you try to download more than 2 or 3 states worth of data.

Easy way to check if you have all loaded data is just do some sample geocodes. If you get no address back or a rating of very high like 100 (which means really bad), then you don't have all data loaded.

Try some examples from manual:

http://postgis.net/docs/manual-2.3/Geocode.html

Note the answer you get back might be a little different from manual by a decimal or so. For example with Tiger 2016 data, I get:

SELECT g.rating, ST_X(g.geomout) As lon, ST_Y(g.geomout) As lat,
(addy).address As stno, (addy).streetname As street,
(addy).streettypeabbrev As styp, (addy).location As city, (addy).stateabbrev As st,(addy).zip
FROM geocode('75 State Street, Boston MA 02109') As g;

I get:

     rating |       lon       |       lat        | stno | street | styp |  city  | st |  zip
--------+-----------------+------------------+------+--------+------+--------+----+-------
      0 | -71.05575058457 | 42.3589792069042 |   75 | State  | St   | Boston | MA | 02109
(1 row)

which is a little different from manual. I think when I wrote the manual the tiger data was vintage 2012 or 2013 and it's changed since.

| improve this answer | |
  • Thanks for your help! So nice to see the original author responding. I'm using Ubuntu and so when I ran the playbook, it threw an error saying ubuntu doesn't have the postgres/postgis versions in your installer. So I commented that out of the file, and I manually downloaded them from apt-get. I then updated the referenced versions in the variables/settings and all worked. Could any of this be a factor? If not maybe you're right it's just limiting me (i think that's what happened) I do have data in there, and some queries work, but 5GB is not enough. How can I get all the data? – NullHypothesis Jul 6 '17 at 17:09
  • One other thing - do you think if I just modify your playbook to use one state at a time (or maybe 2-3), then wait a few minutes, then replace that with a few other states, that it will work in time? I can keep re-running it right? I think the only thing is it throws an error about the drive b/c it's mounted and the file system created, so I assume I have to comment that out? thanks! – NullHypothesis Jul 6 '17 at 17:16
  • I didn't write the playbook. I maintain the PostGIS geocoder. Someone created the playbook to make it easier to use the geocoder on Ubuntu. Well they still limit you, but it's at least easier to spot if you do one state at a time, since you can test an address after each state and then drop and reload state if it fails. I wish I knew someone in census.gov with a clue about their akamai setup. Ultimately it's their akaimai service triggering the block. – LR1234567 Jul 8 '17 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.