1

This question already has an answer here:

I followed the steps suggested by @kazuhito and it is set to the GRASS folder.

However when I close, I get error message.

GRASS Folder is set

enter image description here

Error message when attempting to Close - have to Cancel instead

enter image description here



Original Question

This is branched off from Unable To Clean Incorrect Geometries with Grass

I installed `QGIS Standalone Installer Version 2.18 (64 bit) from QGIS Download Website.

Then I went to GRASS GIS Download page to install GRASS GIS 7.2.1 (current stable)

No matter what I try, every time I run v.clean I get same error:

This algorithm cannot be run :-( GRASS folder is not configured. Please configure it before running GRASS algorithms.

How to fix this?

marked as duplicate by AndreJ qgis Jul 7 '17 at 5:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Could you open Processing | Options | Providers | GRASS GIS 7 commands | GRASS7 folder and check if it is set to your grass-7.2.1 folder? – Kazuhito Jul 6 '17 at 23:29
  • @Kazuhito Yes, GRASS folder is set to grass-7.2.1 , however I get error when trying to close the dialog. Have to cancel instead. Please see updated questions. – Rhonda Jul 7 '17 at 0:13
  • 1
    Please try to revise your question with responses to each clarification sought rather than trying to turn it into a conversation with your commenters. That way what you are asking, and the answer(s) supplied are much clearer. Our focussed Q&A format is introduced in the 2-minute Tour of the site that all of its users are expected to have taken. – PolyGeo Jul 7 '17 at 0:16
  • I think the error itself is not related to GRASS7, but to older GRASS6. Could you open GRASS commands (just below GRASS 7 commands) and deactivate it? – Kazuhito Jul 7 '17 at 0:17
  • 1
    There is a bug in the current QGIS release, see issues.qgis.org/issues/16777. You can switch back to QGIS 2.18.9 until the bug is fixed. – AndreJ Jul 7 '17 at 5:29