2

I have multiple polygons w/ attributes associated with each of them (as shown in the image). I need to bring these into Google Earth and have the attributes look something like they are shown in the other image, on them in google earth. I have done this in the past and had no problem but currently when I try to save my polygons as KML and bring them into google earth I cannot click on them to bring up the attributes.

I am using QGIS. enter image description here

enter image description here

7
  • 1
    Have you tried to use Google Earth Pro? It is free now and you can load the data directly into it without conversion. – ahmadhanb Jul 7 '17 at 15:02
  • @ahmadhanb I don't have a problem bringing in my data. I have a problem with the attribute table not being brought into google. My data in google earth when I bring it in is not clickable. – Shub Jul 7 '17 at 15:10
  • 2
    When you save the polygon, did you select fields to export with KML? By default there aren't selected – aldo_tapia Jul 7 '17 at 15:12
  • @aldo_tapia Thank you I knew I was missing something. That arrow was escaping my vision; it blended right in. This answers my question. – Shub Jul 7 '17 at 15:13
  • @aldo_tapia, sounds like you have the answer, can you add your comment as an answer? – artwork21 Jul 7 '17 at 15:14
1

A drop down was not clicked. After clicking the 'Select fields to export and their export options' arrow, you need to select which layers you want to have brought in to the KMZ file on google earth.

Thank you @aldo_tapia

enter image description here

0

I am not sure what program you are using to export to KML. Are you using ArcGIS, QGIS, etc.? With small datasets like this one, I usually use Google My Maps to export my files to KML. Google My Maps is already a Google application, so converting files to KML is a smooth process. You will have the option to export the entire map or individual layers as KML's.

1
  • I am using QGIS. I just press save-as in QGIS and select to save my layer as a KML file. That has worked for me without a flaw every time in the past but now I must be missing something because the attributes don't get brought it. I tested with an old shapefile that worked in the past to see if the attributes would be brought in again and it did not. I'm assuming there is a button I am missing. – Shub Jul 7 '17 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.