0

This question already has an answer here:

I'm new to GIS but have been learning QGIS for the last few months. I have Windows10/64bit system and I just installed the latest QGIS version 2.18.10, but now I get an error when attempting to run GRASS plugins from the processing toolbox. Error is as follows: "This algorithm cannot be run :-( It seems that GRASS GIS 7 is not correctly installed and configured in your system. Please install it before running GRASS GIS 7 algorithms."

I have seen many post on this topic and have tried every suggestion to fix it to no avail.

I have completely uninstalled, including cleaning up the registry, re-installed 2.18.10 and still same issue.

I'm about to uninstall again and revert back to 2.18.08 which was working prior to this last update. But want to reach out and see if someone has a better solution prior to doing that.

marked as duplicate by AndreJ qgis Jul 10 '17 at 5:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I should have mentioned a few suggestions I have tried: Created a dummy msys directory – Phil_in_Tx Jul 10 '17 at 2:06
  • download MinGW and point to it's msys directory, downloaded GRASS 7.0 directly are a few. Apparently this issue has something to do with the path to a "msys" directory even though some post say its not necessary for GRASS to work in the newer 7.0 version. Created a dummy msys directory, – Phil_in_Tx Jul 10 '17 at 2:12
  • I reinstalled version 2.18.08 and am now able to use the GRASS plugins again. I searched the entire drive and there is no msys directory. The paths in processing options menu for both version show to be exactly the same. So why doesn't 2.18.10 recognize GRASS plugins? – Phil_in_Tx Jul 10 '17 at 2:40
  • 1
    For GRASS 7, you don't need a msys directory. You ran into a know bug, related only to the latest QGIS standalone installer. – AndreJ Jul 10 '17 at 5:36