This question already has an answer here:

While working with the ModelBuilder, I added 2 columns to the data. After you have done "Summary Statistics" according to the GridID, you know the output product in tabular form. I wanted to print the table with the join based on the common column GridID's. But there is a problem here. During the Add Join process, the model wants the input product to be in Table Of Contents. So it want to data as a "parameter". When I run the model from the inside, I say "Add to Display" to the latest product. Thus, the model sees it and accepts it as input. But when I run the model from the outside, it gives error because there is no input / output product in "Table of Contents". How can i solve it?

enter image description here enter image description here enter image description here enter image description here

marked as duplicate by ahmadhanb, mgri, whyzar, Evil Genius, Andre Silva Jul 10 '17 at 14:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


You dont need to add the feature classes to the table of contents. Instead use Make Feature Layer:

Creates a feature layer from an input feature class or layer file. The layer that is created by the tool is temporary and will not persist after the session ends unless the layer is saved to disk or the map document is saved.

enter image description here

  • 1
    To compliment @BERA's answer this is why you need to read the help file, especially the syntax section of the tools. In the Add Join tool, both the input and join tables need to be TABLE VIEWS, a Table/FeatureClass is not a Table View. If you do not know what the difference between a FeatureClass and a FeatureLayer is then you need to read the help file! It's fundamental to almost all operations within model builder. – Hornbydd Jul 10 '17 at 8:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.