3

What might be the reasons for polyline not splitting at the intersection even after using the command 'Split Lines with lines" in vector overlay toolsenter image description here

enter image description here

4
  • 1
    I am afraid that the lines are not snapped correctly that is why they did not split. Try to zoom in to confirm whether the lines are snapped or not.
    – ahmadhanb
    Jul 10 '17 at 11:48
  • @ahmadhanb i have used "check for disconnected islands" plugin to resolve that issue and afterwards dint find any snapping issues.
    – AMAL DATTA
    Jul 10 '17 at 11:50
  • What does the network's attribute table look like? Jul 10 '17 at 12:06
  • @Knightshound There is a new column created titled "network group" and for almost every split, there seems to be a dummy row generated which when selected doesn't highlight any link.
    – AMAL DATTA
    Jul 10 '17 at 12:55
1

It looks like a bug. If there is already a vertex at the intersection point on the line to be split, the lines will indeed be split. However if there isn't, the line remains intact.

It is particularly problematic for lines that touch each others, as you see the vertex for the end of the line but the intersected line doesn't always have a corresponding vertex.

Let's note that is happens even if you snap your points, as snapping ensure proper alignment only, it doesn't create extra vertices.

Proper configuration: on both lines, there is a vertex at the intersection point. enter image description here

Invalid configuration: the line to be cut doesn't have a vertex at the intersection. enter image description here

-1

'Split Lines with Lines' requires two layers, the input layer and the split layer (which I think you have though it's hard to confirm with your images). The description of the tool states:

This algorithm splits the lines in a line layer using the lines in another line layer to define the breaking points. Intersection between geometries in both layers are considered as split points.

Your network isn't intersecting, but touching. Try the tool again but with the splitting line layer overlapping the 'Input Layer'

4
  • sorry i have been a little vague about the issue.. I have a road network that should be broken down (at intersections) into links. The Whole network is in a single layer. Therefore I gave the same layer as input layer as well as split layer. In some cases it worked and in others it dint (both intersecting and touching).
    – AMAL DATTA
    Jul 10 '17 at 11:43
  • 1
    This is false. Touch is a special case of Intersect where the interior of A is disconnected from the boundary of B, but in both case the boundary of A has a relation with the boundary of B. See this illustrated definition. Also I just tried the tool with segments touching each other and the lines are broken as expected
    – JGH
    Jul 10 '17 at 12:31
  • @JGH what you mean to say is, that there might be snapping issues?
    – AMAL DATTA
    Jul 10 '17 at 12:47
  • 1
    @AMALDATTA while the snapping issue is a plausible explanation, my comment meant to say that this answer is plain wrong.
    – JGH
    Jul 10 '17 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.