1

I have a shapefile which has accumulated quite a few topological errors (>400). Most of them are gaps and overlaps, which I know how to solve. However, when I use the "Topology Checker" Plugin checking my layer for gaps, it also identifies the entire extent of my polygons as being a gap (see imageThe red box around my polygons is identified as a gap).

This is clearly a mistake and I am worried that these problems in the shapefile are the reason for me not being able to use other processing tools (e.g. the difference tool does not work properly on this layer).

How can I fix or understand in detail what the reason for this mistake is?

I am beginner at GIS and I am particularly interested to find out where I am using a wrong mindset or why am I creating these errors.

This is what I have done until now: I have had an original shapefile without this error. I used union in ArcView 3.3. (because using Union in QGIS at that point led to many ruptures in the polygons and splinter polygons).

Is there a problem in compatibility in moving shapefiles between the two programs?

EDIT: I have been trying to get around this error and started again from the original data with only one invalid geometry. After using union many errors appeared again (but not the one in the image). Then I used v.clean from Grass and this solved many other problems, but the error from the image showing a gap for the entire area reappeared. I am confused...

1

Problem has solved itself (kind of). After using v.clean I manually cleaned the few remaining problems (gaps and invalid geometries). And after having cleaned them, this big gap disappeared as well and now the topology checker does not find any problems, I am happy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.