1

I try to label some geologic features with Maplex. A given condition for naming is that some geological units start with a double comma ,, . So the label should look like ,,ta or ,,ya . Whenever I try to label, Maplex is not showing the leading characters. Using the standard label engine works and shows the right result, but causes more problems in conflict detection. Any ideas how to convince Maplex to give me the ,, ?

In Germany a , usually is used as decimal sign in numbers, not as separator. So my PC is set to use , as decimal sign.

3
  • You can use quotes to do this like "<BSE>" &",," &[Name]
    – Mapperz
    Jul 12, 2017 at 15:13
  • Thank you Mapperz. Unfortunately it's not working. My variable [LABEL] contains a string ,,ta and many others, some with leading,, some without. so its a bad idea to put ,, fixed at the beginning. Anyways Maplex is not able to show me the string with its leading ,,. Even if i put a string like ",,"&[LABEL] Maplex cannot show me the ,,. If I use the regular labeling method it shows the string in its right way, but in very bad placement.
    – user89877
    Jul 24, 2017 at 10:53
  • Fixed! Maplex takes , as stacking separator. Disabled stacking and , appears.
    – user89877
    Jul 25, 2017 at 5:50

1 Answer 1

1

You don't need to disable stacking altogether - it is possible to delete individual stacking characters by following the instructions on the Adding and removing stacking characters of the ArcGIS Desktop Help.

1
  • You are absolutely right, its also possible to delete individual characters. Thanks for the complement!
    – user89877
    Aug 2, 2017 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.