1

This question already has an answer here:

All day I was struggling with QGIS 18 and GRASS 7. My mission was simple: import a file in QGIS 2.18, run v.clean and then go home. Unfortunately it turned out that my mission was not that easy.

First of all, although I read everywhere that GRASS is now a component of QGIS 2.18, when I tried running the plugins, received an error telling me that I needed to configure the working directory for GRASS.

I tried different things (see the list below) doing that and I failed many times.

  • Installing GRASS 7 separately and moving the contents of the folder in the apps subfolder of QGIS, in order to be able to point it in the program

  • Found out that there already was a grass installation in my QGIS folder. Linked the application to that folder

  • Read what was written in the QGIS documentation about configuring grass, followed the steps, failed.

  • Installed MSYS, linked the folder to the corresponding one in QGIS (heard that GRASS 7 did not require MSYS)

  • Started the GUI of the software, got an error while trying to import the shapefile, a module (forgot the name) was missing and the command failed.

Can anyone guide me step-by-step on how I can configure the software in order to work properly?

Thinking as a last resort downgrading to QGIS 2.14 and hoping for the best.

marked as duplicate by PolyGeo Jul 15 '17 at 6:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Rather than asking someone write out the steps for you I think you should list the precise steps of your latest attempt to let us know what you have tried and where you are stuck. – PolyGeo Jul 15 '17 at 1:20
  • If you are running the latest QGIS 2.18.10 on Windows, the only solution for now is downgrade to 2.18.9: issues.qgis.org/issues/16777 and gis.stackexchange.com/questions/246022/… – AndreJ Jul 15 '17 at 5:47
  • Why is my question duplicate? My QGIS runs on Windows 10. Thank you! – Azar Jul 16 '17 at 20:14