4

Has anybody managed to successfully connect to open a MS Access *.accdb database from QGIS using ODBC?

All the Q&A, tutorials, guides and videos I've found work with *.mdb files and ESRI geodatabases. I tried *.accdb but QGIS gets frozen.

Details:

Testing environment

  • Windows 7 64bit

  • MS Access 2016 32bit

  • ODBC drivers used: MS Access Database Engine 2016 32 bit (*.mdb, *.accdb)
  • Using ODBC 32bit config in Windows (C:\Windows\SysWOW64\odbcad32.exe)
  • Using QGIS 2.14.16 32bit

In QGIS, I use:

  • Add vector layer > Database > Type ODBC > New
  • Type ODBC > Name (name1) > Database Name (nameA)
  • Test Connect: "connection to x was successful"
  • Press OK --> QGIS gets frozen

I can read the same ODBC database from other applications (SQLite, MapInfo), so there is no problem with the ODBC side of it. It looks like something's not right on the QGIS side.

Does anybody know if this connection should work / why is it not working?

closed as primarily opinion-based by neogeomat, whyzar, nmtoken, xunilk, BERA Apr 9 '18 at 4:59

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise. If this question can be reworded to fit the rules in the help center, please edit the question.

  • It works for me (Win10 / Ac2010), but it takes a little bit (20s). You should convert DB to AC 2007/2010 (for testing) – Mike Jul 17 '17 at 16:07
  • Using *.mdb the ODBC connection worked with no issues. The connection was immediate. I guess *.accdb can be considered a feature not functional in QGIS yet. The freezing behaviour can be considered a bug though - QGIS should ideally display an informative error instead of freezing. – jberrio Jul 18 '17 at 3:02
  • I think this is more the DB version (2016). My AC2010 accdb works fine. – Mike Jul 18 '17 at 15:27

Browse other questions tagged or ask your own question.