0

I'm attempting to interpolate the NU national grid square of Ordnance Survey's terrain data (10m intervals). If I interpolate with IDW, I encounter no issues and the raster pixels are square in shape as they should be. When interpolating with TIN (much better for conducting viewsheds over) the NU national grid square returns non-square pixels after the interpolation process. When using the viewshed plugin this creates obscure viewshed as shown here. Can anybody else confirm you receive non-square pixels?

When trying to fix this, I was given an error "wkb access out of bounds".

This error has been appearing more and more ever since I first encountered it to the point where its occurring consistently with every TIN interpolation. I have tried the following:

restarting QGIS and the computer

different national grid squares

meticulously gone over CRS selections

checked the validity of the contours

clipped the contours to smaller areas

downgraded my version of QGIS - all at no avail.

I'm using QGIS 2.18.10. I'm conducting the TIN interpolation by navigating to Raster > interpolate and using the viewshed plugin (or would have been if the interpolation worked).

  • Could you elaborate how you have created the contours? Does it keep the original extent (or partial)? – Kazuhito Jul 17 '17 at 14:21
  • They were downloaded from Ordnance Survey. The contours download in national grid squares for the UK, each square sub sequentially being split by a further approximately 10 squares so they must be merged together to form a single national grid square. Not sure what you mean, original extent or partial extent. – James B Jul 17 '17 at 14:26
  • TIN interpolation gives excellent output but it is hard to work with (just in general sense), especially when we have unmatching bounding box / extent in our dataset. If v.clean does not help to solve the issue, consider idw. Or you may find r.surf.contour (after rasterize) is preferable option. – Kazuhito Jul 17 '17 at 14:40
  • I just don't uinderstand why QGIS is giving me this error now when in the past it's worked just fine, even with the same dataset and interpolation method. – James B Jul 17 '17 at 14:56
  • 1
    Adding your workflow(s) to your post with focus on differences between previous and current (if any), is appreciated. – Kazuhito Jul 17 '17 at 15:26
0

I was importing my contour data from a spatiaLite database. If I used the raw files I imported into the database instead, the error was no longer appearing. If I clip the contours, the error will re-appear - this does not appear to be an issue as the interpolation plugin manages just fine despite working off large contours data sets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.