1

I am using QGIS 2.18 and have a workflow that requires going offline with some of the data. My workflow is fairly simple:

  • Go to Database - Offline Editing - Convert to Offline Project. Select the layers that will be edited offline.
  • Edit the offline layers are required.
  • Go to Database - Offline Editing - Synchronize

The sync process runs and is successful, but the result creates duplicate entries in the master (online) database for any of the features that were edited or created offline.

I have tried using SpatiaLite and PostGIS as my master (online, source, whatever you would like to call it) database, with the exact same results.

Any suggestions?

1

This is something that I have noticed recently when working on QGIS 2.14.9 LTR on a work machine, and 'offlining', and 'syncing' from, and to, a PostGIS database.

I have tried testing the same workflow and files on a personal machine running both 2.14.14 and 2.18.10 and the Offline editing works fine, I don't get duplicates.

So, although you haven't said which release of 2.18 you are using, I suspect that the problem will be solved by downloading the latest release of 2.14 or 2.18

  • I am using 2.18.9. I will try 2.18.10 and report back. – K. Hartman Jul 18 '17 at 17:55
  • I have downloaded 2.18.10 and verified that the issue still exists. I have tested using PostGIS and SpatiaLite as the master database. – K. Hartman Jul 19 '17 at 2:38
  • Ok. That is very interesting, when I tested 2.18.10 on my personal computer I did not get duplicates. This clearly needs more investigation - so my answer is not the answer. But rather than delete it for now, I shall leave it in the hope of looking into this and editing it with a solution. It is something that I need to solve for myself and about 10 users in a similar situation. From my previous trials I had assumed that it was a QGIS version issue. – Martin Hügi Jul 19 '17 at 17:09
  • This may help. I created a very simple Layer in SpatiaLite that is a point with an autoincrementing primary key as the only attribute. I added 2 points while online and saved the Layer Edits and the points were assigned primary key values 1 and 2, as expected. Then I sent offline, added 2 points and saved the Layer Edits. They were not assigned any primary key value. After Sychronizing the changes the 2 new points had primary key values of 3 and 4 and duplicates were created with primary key values of 5 and 6. – K. Hartman Jul 19 '17 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.