1

I'm having trouble with QGIS. I have tried many installations of it (removing the old one each time) and they are all having the same issue. It may be my computer but I don't even know what to look for. All of my other programs run fine.

I tried QGIS 2.14 32 bit, 2.14 64 bit, 2.16 32 bit, 2.16 64 bit, 2.18 32 bit, and 2.18 64 bit.

The problem is that when I go to click on any menus, drop downs, or buttons, either nothing happens or it shows only the edges of the drop down - no text or backgrounds. When I try to type in boxes, nothing happens. When I try to click a button to do something, nothing happens. The most I've ever been able to do was to add one vector layer with one field. Anything additional to that starts the problems.

I've rebooted my computer several times. QGIS is the only thing running. There are no other windows open. My computer is only ever using about 8% of its full potential at any one time running QGIS, so it's not "hanging".

I've tried my wired mouse and my touch pad. Both are doing the same thing. No problems with my mouse in any other program. Just verified all the drivers are up to date on both mice.

Any ideas of how to fix the issue?

Computer specs:

  • Windows 10 Home
  • Processor - Intel Core i7-6700HQ CPU @ 2.6 GHz
  • Graphics - NVIDIA GeForce® GTX 980M
  • 16 GB RAM
  • System type - 64 GB
  • 1
    It sounds like you're having a really bad time.. have you tried running in compatablity mode? pearsonsupport.helpserve.com/Knowledgebase/Article/View/210/21/… or support.microsoft.com/en-us/help/15078/… or in a Windows 7 virtual PC docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/… – Michael Stimson Jul 19 '17 at 0:45
  • I have a coworker with a similar problem. At first I thought it was a Qt-related issue with perhaps another incompatible Qt installation, because the UI wasn't reacting. But I only found one other application using Qt and removing it didn't solve the problem. I tried the QGIS nightly build and it didn't work either. I haven't ruled out Qt as the problem, but on the other hand, I haven't found another suspect. I don't know if QGIS can be setup to log any kind of warnings, but again the problem might be outside QGIS. – Chau Jul 19 '17 at 6:27
  • 1
    Apart from Qt, a different version of Python or the msvc runtimes may cause the problem. I suggest to put QGIS into a virtual box, or start it from the command line of a OSGEO4W setup to see error messages, see gis.stackexchange.com/questions/84790/… – AndreJ Jul 19 '17 at 9:27
  • @Andrej, running QGIS nightly from command line didn't return anything for me. Since the UI doesn't react on anything its very difficult to use the print-to-logfile proposed in your link. – Chau Jul 20 '17 at 7:09
  • I guess the virtual box is the only solution for you. You can even put any Linux distribution in there. – AndreJ Jul 20 '17 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.