1

I have recently run into problems with maplex label engine not being enabled on new layers. I played around in the Label Manager and that didn't work immediately. It randomly started working on the new layers 10 minutes later. I would like to know how to make sure maplex label engine is enabled for any new layers I add to future maps so I can place the labels properly. It was a Placement Properties issue I was having, only showing the default options instead of the maplex options.

2 Answers 2

1

You don't state which version of ArcGIS you are using, but it is possible to set Maplex to be the default label engine for new map documents. ArcGIS Help - Setting Arcmap options

If you are still having trouble, most problems can be solved by either resetting normal.mxt or rerunning your installer and choosing 'repair'.

1
  • Sorry it's 10.3.1 to be clear Commented Aug 2, 2017 at 11:56
0

Here is how I turn on Maplex engine on my ArcMap and on my ArcGIS Pro.

ArcMap first:

enter image description here

enter image description here

enter image description here

enter image description here

Here is Esri document

Enabling the Maplex Label Engine and adding the Labeling toolbar

https://desktop.arcgis.com/en/arcmap/10.3/map/working-with-text/enabling-maplex-for-arcgis-and-adding-the-labeling-toolbar.htm


How to turn on Maplex at ArcGIS Pro

enter image description here

enter image description here


If you use standard labeling engine, later on, when you publish it to ArcGIS Server, you cannot create custom labeling with ArcGIS Online map viewer.

By using Maplex engine, you can create custom labeling with ArcGIS Online map viewer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.