8

The Dissolve tool is not working for me when I use ArcGIS Desktop 10 to dissolve a shapefile.

It says:

ERROR 999999: Error executing function.

It works perfectly when I use version 9.3.

Any help?

23

I have found that not all tools work when your geoprocessing environment is set to run in the background. I believe that Dissolve may be one of these. Change you GP environment to Disable Background Processing and then give it a try.

I have not tested this but may be worth a try

| improve this answer | |
  • You're a genius! It worked perfectly – Kevin Oct 12 '10 at 1:39
  • 4
    @Kevin Don't forget to accept CDBrown's answer, since this answered your question. It's always nice to give thanks where it's due. – Michael Todd Oct 12 '10 at 1:56
7

Try this: Run Repair Geometry 1st and then run Dissolve.

| improve this answer | |
2

The 99999 error can be caused by any number of reasons; system resource availability or dataset issues are a couple possibilities. While disabling background processing may seem to have solved the immediate problem it actually is only a workaround to another problem. All tools (aside from the 5 or 6 which absolutely cannot run in the background) do function through background processing - there however might be one off cases or bugs for a particular situation which causes tools not to run. In general, the dissolve tool functions fine through background processing.

| improve this answer | |
0

I have found that I need to go into the environments and specify that the processing extent is the extent of the shape file in question. For some reason the default extent is off.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.