The dissolve tool is not working for me when I use ArcGIS 10. It works perfectly when I use version 9.3. Any help?

  • What's the error message? – Derek Swingley Oct 11 '10 at 16:40
  • It says error 999999: Error executing function. – Kevin Oct 11 '10 at 18:09
  • Failed to execute (dissolve) – Kevin Oct 11 '10 at 18:09
  • Michael Todd, I'm dissolving a shapefile – Kevin Oct 11 '10 at 18:10
  • Is it possible that the size of my database is affecting my ability to run the dissolve? I have about 30,000 buffers that I'm trying to aggregate, but when I attempt a dissolve, I get the 99999 error. I disabled the background processing, which didn't work on the entire dataset, but when I focus my frame on half of my territory (and adjust my environments) it appears to work. Is there a limit to the number of polygons that you can dissolve at one time? Also, where is repair geometry located in ArcGIS 10? I'd like to try that next if this current attempt doesn't work. Thanks!! – Erin Nov 7 '11 at 22:09

I have found that not all tools work when your geoprocessing environment is set to run in the background. I believe that Dissolve may be one of these. Change you GP environment to Disable Background Processing and then give it a try.

I have not tested this but may be worth a try

| improve this answer | |
  • You're a genius! It worked perfectly – Kevin Oct 12 '10 at 1:39
  • 4
    @Kevin Don't forget to accept CDBrown's answer, since this answered your question. It's always nice to give thanks where it's due. – Michael Todd Oct 12 '10 at 1:56
  • 8
    @Kevin -- Agreed with Michael. Also, don't forget to ritually shake your fist in anger in the general direction of Redlands CA, both for the bug and for the useless error message. – Dan S. Dec 9 '10 at 20:22
  • This fix worked for me when getting error 999999 when doing dissolve. – MathiasWestin May 26 '11 at 8:32
  • Euclidean Allocation seems to be one of the tools that doesn't work with background processing. Has anyone else had the same experience? – cwb Apr 23 '12 at 18:49

Try this: Run Repair Geometry 1st and then run Dissolve.

| improve this answer | |
  • 1
    Thanks VietThanh Le! Repair Geometry did the trick for me. Disabling background geoprocessing had no effect. – user3010 May 18 '11 at 12:48

The 99999 error can be caused by any number of reasons; system resource availability or dataset issues are a couple possibilities. While disabling background processing may seem to have solved the immediate problem it actually is only a workaround to another problem. All tools (aside from the 5 or 6 which absolutely cannot run in the background) do function through background processing - there however might be one off cases or bugs for a particular situation which causes tools not to run. In general, the dissolve tool functions fine through background processing.

| improve this answer | |

I have found that I need to go into the environments and specify that the processing extent is the extent of the shape file in question. For some reason the default extent is off.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.