2

I have a RGB 3-band GeoTiff which gives me a nice looking when loaded in ArcGIS. Now i want to convert it to a simple colored image. My goal is to have an image which can be displayed the same in different software. (I know that i can change symbology of raster in every software, but i don't want to do that.) I have no analysis or processing need for this image, and only its view is important for me. How can i do that in ArcGIS?
What i have done: using Copy Raster tool, but unfortunately 'RGB to colormap' option is grayed out for this raster. I also tried Raster Calculator to add band values together, but output is not colored.

  • If you want to keep the same view in different software, it is better to leave it in RGB (3*8bit), otherwise you will depend on a colormap that will not be interpreted by any software. – radouxju Jul 20 '17 at 11:38
  • I don't understand why this is impossible. For example, I can use Print Screen bottom and have a copy of current view in jpg format which always will be displayed the same. So why GIS software can't produce this output for me? – ALalavi Jul 20 '17 at 12:07
  • a jpg is an RGB file, and you can change it displays (darker/more contrast/ or even modify the band order to change the colors). – radouxju Jul 20 '17 at 13:27
  • @Luke this solution does not work. It produces 3-band images. A new soultion: It is strange that File>Export Map nearly produces what i want. I set 8-bit in that dialog and it creates an image with Color Map which is viewed exactly the same in QGIS and in Windows. Though, it introduces small noices in output picture. Because of this kind of solutions, I think there should be a way in GIS tools to produce the same output without noise. – ALalavi Jul 20 '17 at 14:44
  • A small clarification: In fact, my original problem goes to GeoServer and creating a good SLD for raster files. I want to avoid creating that complicated SLD. If i can convert my 16-bit RGB image to a single-band image while preserving the view (like all other normal photos in windows which have fixed view ), i can be sure that GeoServer displays the image as it is displayed in windows or ArcGIS. – ALalavi Jul 20 '17 at 14:50
1

You need to change the bit depth (pixel type) to 8_BIT_UNSIGNED for this.

  • Helene was right. My data is 16-bit and by setting pixel type to 8-bit, now Copy Raster tool woks. But unfortunately it gives a 1-band image which is really darker than original image. My problem still exist (i.e. producing a 1-band image with the same view). Colormap does not suit to original view. – ALalavi Jul 20 '17 at 11:59
  • I think the darker display is only due to the default stretch applied to the image upon loading. The actual image is the same as the original one, and resetting the default stretch to "None" should solve this. You might see different results in different software, because the parameters of default way of displaying the image varies. – Hélène Jul 20 '17 at 12:42
  • @Hélène Your post could be considered as an answer, but please give more information as why it is so. We prefer longer answers. You could edit your post to add some of the content of your comment. – radouxju Jul 20 '17 at 13:37
  • Finally, i could get it to work. First exporting data with checkbox 'Use Rederer' and then Copy Raster tool with checkbox 'RGB to colormap.' Meanwhile, this produces some NODATA values which should be handled in another way. – ALalavi Jul 20 '17 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.