0

I am attempting to combine six rasters using the ArcGIS 10.5 Combine tool. I ran this on three similar rasters and it worked. However, when I run with the new rasters it returns an empty raster with no records, but the stated value range (-)128 to 127.

The inputs are all 8-bit signed integers, projected using the same snap raster, and were reclassified to have a value 1 (with no "No Value"). I have tried running Combine using the same snap raster as used to project as the extent, and using the intersection of the layers (which theoretically should be identical anyways). However, it still results in the same error.

These two posts came across similar issues, but I have already tried the suggested approaches:

Has anyone seen this behaviour and can suggest a solution?

  • So your all your input rasters were reclass to have either 1 or "No value"? remember that if there is any cell with "null" or "No Data" value the combine value will be "no data"... make sure that your raster values actually intersect to each other. Can you provide more about the raster's data/values? – Delonix R. Jul 24 '17 at 15:51
  • @DelonixR., actually, it seems you are correct about "No Value" being the issue. I checked before, but it seems an error was introduced, possibly from an extent issue. In the end, what fixed it was: (1) Reclassify the original data as 1 for the value of interest and 0 for No Data, and setting (a) the extent to a bounding feature, and (b) a snap raster (both were the same size, but for some reason it did not work if only snap raster was set (?). (2) Keeping the resultant 'square' raster. (3) Running Combine. (4) As a final step, clipping the combine output to a vector feature boundary. – Dan Jul 25 '17 at 5:32
  • Just a hint: sometime you can use a real "code/number" value that for you means no value. Say 10 will be a value for true, and you'll have 1 for null or no data. That way you 'trick' combine and force it to combine the values in your raster's cells. At the end, you can realize which cells had no value, but there will be an actual output. Combine it's a great and unique tool. However, It takes some time to learn how to work with it... Try it with rasters with attritubute values associated to the raster... glad that you have your problem fixed! – Delonix R. Jul 25 '17 at 12:15
  • Thank you for the tip. In the future I will definitely use 'real' values. I am used to running similar operations through raster calculator, so often use "0" for areas/values that are not of interest. I did not see that the extent issue was introducing NoData values at first; ArcGIS was showing the raster as just "1", with no NoValue shown/specified in the attribute table for the irregular shaped areas outside of my area of interest. – Dan Jul 25 '17 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.