1

I've been working on data from OpenStreetMap in QGIS. I've been trying to add an image of my site which I got from Google Earth Pro so I could continue adding information that isn't available on OpenStreet Map. But I can't seem to georeference it properly.

I'm just starting to use QGIS so I've followed the georeferencing tutorials and tried a bunch of things to try to sort it out but I've run out of ideas. I've tried with different CRS (WS84, WSG/Pseudo Mercator). I've input the coordinates that I got from Google Earth, trying both DD and DMS and including the "-" for the Y since I'm in the South. I've also tried different transformation types, tried disabling or enabling "on the fly" projection etc. But when georeferencing, the image and the openstreet data do not correspond. Most of the time, the image appears in the wrong location (next to my site), a lot bigger than it should, and completely flat.

Has anyone got any idea of what I might be doing wrong or what I've missed in the georeferencing procedure?

  • The QuickMapServices plugin allows you to load Google imagery directly. You need the "Contributed pack" from More services. – AndreJ Jul 24 '17 at 9:31
  • first, be aware about licence when you publish to OSM. You should use data witch are open licenced. Then for the trouble you have, could you send a screen shot of the result . Could you also be more specific of the input you try to project under QGIS. It seem you don't have an already georef image (see next comment). Do you have a world file witch it fixing pixel size and origin of the images. If not, you need to use a tool to create it (set the coordinate of a minimum of 4 pixels in your input image), or export georef data from Google Earth pro. – Hugo Roussaffa - GeoDatup Jul 24 '17 at 9:45
  • Image extension and World file extension : | tif | tfw / tfwx / tifw | | jpg | jgw / jgwx / jpgw | | bmp | bpw / bpwx / bmpw | | png | pgw / pgwx / pngw | – Hugo Roussaffa - GeoDatup Jul 24 '17 at 9:45
  • for georeferencing, this is explain here – Hugo Roussaffa - GeoDatup Jul 24 '17 at 9:54
1
  1. Why do you need to georeference an image from Google Earth Pro when you can easily add Google Satellite as a WMS layer in QGIS install the OpenLayers plugin and selecting Google Satellite?
  2. If you still want to georeference an image from Google Earth Pro (maybe you want one registered in 2011, as I needed to do), this is how I usually do:
    • First thing: in GEP, open Tools>Options and select UTM from the list of possible lat/long visualisations Google Earth Pro options panel
    • close the options panel and zoom to get the image you wish (you MUST NOT change the zoom level anymore after this step
    • add 4 waypoint and place them at the corners of your image (as showed in the image below): when you add a waypoint, change the symbol to the small white circle with a dot in the center: it will make it easier to put the coordinates in QGIS. Every time you add a waypoint, you'll take note of its coordinates as shown in the properties panel: there, you can also see the UTM zone (33 T in my case), you will need it. You won't give it a name. You can make the symbol as small as you want, so that the image will look better. Add a waypoint and take note of its coordinates
    • When you're done, you open the Save Image tool in GEP and turn off all the map options (see image below). Then, you set the maximum resolution available and you save your image. Map option settings in GEP
    • Open the Georeferencer plugin in QGIS and add your image. Set the correct SRS (in my case it will be WGS 84 UTM 33 = EPSG:32633, in yours it will be WGS 84 UTM something else that you'll have noticed in the properties of your waypoints, EPSG:326xy). Associate the precise center of your waypoints in the 4 corners with the coordinates you adnotated from GEP.
    • In the Transformation settings, set Linear as Transformation type and Nearest Neighbour as Resampling method and make sure that the SRS is still the correct one. Save.
    • Click the play button and it should work properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.