5

I tried to save my project under a new name ("Save as"), as I often do. However, the screen just sort of blinks; then stays the same and does not allow me to enter the new name, etc.. I have upgraded to the latest version of QGIS. I tried doing this with an earlier version of my project (saved under a different name) and it worked ok. Any idea what's the matter with this file, or what I need to do?

Here is a link to it.

Here's a link to the previous version, which did not have this problem.

  • 1
    could you precise which version of Qgis did you installed and what is your OS ? – Hugo Roussaffa - GeoDatup Jul 25 '17 at 9:21
  • I just updated to the current version, 2.18.11. I am running Windows 10. – TVZ Jul 25 '17 at 19:08
  • I would unninstall QGIS and install it again. I have QGIS 2.18.11 in my computer and I don´t have that problem. – Ernesto561 Jul 28 '17 at 3:27
  • Can you add which data sources you have in your project? Do they work in a newly created, empty project? If yes, you can compare the project files in any text editor. Maybe you can upload the project files somewhere. – AndreJ Jul 28 '17 at 5:36
  • Did you uninstall 2.18.10 before installing 2.18.11? When I try to install latest version(2.18.11) I get a warning that older one will be uninstalled. – senol ozgur Jul 28 '17 at 6:10
0

i found out that using a colon ":" in a project title causes problems (at least under windows). I think because the title is suggested as filename, the colon causes the "save as"-dialog to some kind of crash due to the colon presenting a disc-name like c:\Windows...

I don't know if this or a similar problem is an issue under other operating systems than windows.

Funny thing is that if you use a colon in the title of an already existing qgs-file, the "save"-button still works.

Workaround: Save the project without colon in the title and insert the colon to the title-tag of the gs-file with a text-editor. After that you can re-open the project, do changes to the project and use the "save"-button!

6
+50

Open the file with a Text editor like Notepad++, the title tag is set to

Pt O Cult Resource Map @ 1:7200

The problem seems to be with that. Changing that line to say "Resource" and saving the file allows you to do "Save As" when its opened from QGIS.

EDIT: Added picture

enter image description here

  • Don, I totally don't know what I'm doing, but I downloaded & installed Notepad++; I then opened my project file. The second line was, <qgis projectname="Pt O Cult Resources Map @ 1:7200" version="2.18.11"> I changed "Pt O Cult Resources Map @ 1:7200" to simply "Resource". I then saved the file and opened it in QGIS. It still would not "save as". Did I understand you correctly and do what you intended? By the way, when I close QGIS, I get a "Crash dumped" message. – TVZ Aug 2 '17 at 11:23
  • The third line is what I changed to "Resource". I edited my initial answer to highlight the line I changed. You might wanna download a fresh copy and try that again. – Don Aug 2 '17 at 11:36
  • My projects usually have an empty title and projectname. So I doubt these entries have any influence on the saving. – AndreJ Aug 2 '17 at 11:41
  • @AndreJ, that's what I thought as well. But figured I will open his file and take a look at it. I got the same flashing response when I attempt a "Save As" on his original document. After changing that line and saving the file. The "Save As" worked. So, it's either the problem gets fixed by me messing with the qgis file or a combination of the special Character and colon is causing the problem for @ TVZ. We might not know the cause of the problem. I opted to share what fixed the problem with him. – Don Aug 2 '17 at 11:46
  • 1
    @TVZ, glad to hear that did it for you as well. In case you are wondering how I found that line, I used Microsoft's Process Monitor (ProcMon for Short). I had that running alongside QGIS during the "Save As". I then filtered out all the captures except for the QGIS ones. ProcMon captures a lot. A createfile action captured by Procmon from QGIS seemed to be faulting on the title. I changed that and bam it worked. – Don Aug 2 '17 at 17:33
1

I had the same problem but was able to save as normally once I deleted the "Project Title" out of the Project Properties section. If you entered a title for the project, just delete it and then try saving.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.