When using the Erase geoprocessing tool from the Analyst Toolbox I get the following error "ERROR 999999: Error executing function. The geometry is not M-aware Failed to execute (Erase)."

With small subsets of my data, there's no problem running the tool, but when I run it on the entire dataset it seems to give me the aforementioned error. I have tried the following steps to try and fix the problem:

  • Repair Geometry of both of my polygon shapefiles
  • Turned off M-aware under my environmental settings

I am using ArcMap 9.31.

  • are you up to date with service packs? I think i remember something about this getting fixed in a sp. – gotchula Nov 25 '10 at 20:33

I had a similar problem with the Tabulate Intersection tool (using 10.4). I found the suggestion to place the resulting table into a geodatabase from here: https://geonet.esri.com/thread/13680

It fixed the problem!

This problem could origin in the fact that some of your datasets are M-aware and others are not. If you don't need these values you can easily remove them by using the conversion tools. If on the other hand you do need those values, you can add them where needed, too:

  • Open Conversion Tools toolbox
  • Use e.g. Geodatabase: Feature Class to Feature Class
  • Click on 'Environments...'
  • Under 'General Settings' enable or disable 'Output has M values'
  • Run the tool

Do that for all affected feature classes and replace the original ones. You can check if a feature class has M values by right-clicking on it in ArcCatalog and select the 'General' tab, look for 'Geometry Properties'.

Some users report that running the multipart to single part tool was solving their problem.

I don't know about fixing M-awerness, but if you want to bypass the problem, the ET Geowizard toolbar (found in: http://www.ian-ko.com/) has a erase tool (which I use instead of the ArcGIS's tool).

This error message shows up occasionally while running a python script. Not sure if it is memory related, but simply quitting the application and restarting sometime solves the problem. Failing that, Multipart_to_singlepart may help as another user mentioned above. My last suggestion might be to compress or compact your database prior to the step where it is failing.

I found converting to shapefile is a work around as well.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.