0

Topology will not identify overlapping polygons using qgis 2.18 Error: otb was not found or is not correctly installed.

I promise this tool worked yesterday just fine. Today it won't work due to the above error. I installed OSGeo4W on its own and in the processing toolbox in qgis I set the file to what you can see in the image. What am I doing wrong?

This is what I want to get rid of. For some reason it won't pick up the overlapping geometry

1

You can download Orfeo toolbox as a standalone toolbox, then choose the correct path where the Orfeo applications folder is located. In the following path, I extracted the toolbox into the Download folder and searched for applications folder and selected it, but you can extract the toolbox into any folder you like:

\\PC-Ahmad\Download\Orfeo\OTB-5.6.1-win64\OTB-5.6.1-win64\lib\otb\applications

enter image description here

  • Hi ahmadhanb, I just tried what you suggested and I still get the same error followed by QGIS crashing – Jess Jul 25 '17 at 19:19
  • I suggest to completely uninstall QGIS and install it again using OSGeo4W installer and use advanced installation and there you can choose QGIS and Orfeo toolbox together. – ahmadhanb Jul 25 '17 at 19:29
  • I have done this and now have OTB installed but the tool is still failing to work will need to have another hunt around to see why it is still not working. – Jess Jul 25 '17 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.