2

I wrote a toy plugin for QGIS-3 (2.99 Ubuntu 16.04), which worked for quite a while. But after a recent upgrade, the plugin disappeared from the QGIS toolbar while the rest of QGIS seem to be working fine.

I have checked that the ~/.qgis3/python/plugins/ folder is still present. I tried to use pb_tool deploy to re-install the plugin. But the plugin still wouldn't show in the toolbar.

Does someone know what could have gone wrong?

4

Perhaps the qgis3 data folder has been moved to a different place with the upgrade of nightly versions?

With a freshly installed QGIS2.99 (revision dcec6bb), the trusted pluginbuilder3 plugin seems to install to ~/.local/share/QGIS/QGIS3/profiles/default/python/plugins/pluginbuilder3/ instead of ~/.qgis3/...

So, the plugin should be copied to:

.local/share/QGIS/QGIS3/profiles/default/python/plugins/

You can similarly install and locate a well-known plugin to find out the right folder for your machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.